Persistent Errors: 'Reading Content Failed' in Web Browsing

Hey there,

I’ve been experimenting with the new web browsing feature, but I’m encountering the ‘Reading content failed’ error quite frequently. It seems to be happening around 90% of the time.


I got the same issue :sweat_smile: Hopefully they will fix this.


iam getting the same error since the start. everywebsite it tries the same error. [quote=“hasseinbey, post:1, topic:208615, full:true”]
Hey there,

I’ve been experimenting with the new web browsing feature, but I’m encountering the ‘Reading content failed’ error quite frequently. It seems to be happening around 90% of the time.

That error is all I’m getting. I bet it counts toward the message limit too.


I’m getting so many click failed and reading content failed errors, that it renders the browsing feature nearly useless.

1 Like


1 Like

Some potential solutions:

  • websites need to allow ai crawlers to access, which is not likely as it not only bypasses their monetizing strategy (ads, signup walls etc)
  • gpt-4 should take the user’s browser configuration, such as agent and cookies, to make the request, in essence spoofing the request to be made by the user. It should then also be smart enough to click any UI elements blocking the content (signup modals, cookie consent etc).

A big issue for content providers is the likelihood of (accidental) plagiarism. However, this is inherent to LLM technology that is able to access the web. It should be dealt with on a higher plane imo like global/EU/national legislation. Legislation could:

  • prescribe LLM output to be clear about the author (the LLM) and the sources (inline links to footnotes), in order for humans to immediately understand what they are looking at.
  • disallow publishing exact LLM output under another name

Both the above suggestions are technologically implementable and/or enforceable, so it is very likely going in that direction.

1 Like

I’m getting the same issue for “reading content.”

Yesterday was constantly getting ‘click failed’ no matter what. It’s now this error…

Come on openAI… the free KeyMate plugin with likely 100x less resources than yourselves shouldn’t be vastly superior…

If you want to charge separately for web browsing I’d happily pay for it. Alternatively, let me put my own google API and Search Engine ID in and use that.

The GitHub google search plugin I’ve tried fetches results rapidly but doesn’t seem to be able to visit any sites like it should, if anyone has a better one please let me know

1 Like

It does count toward the message limit. As does regenerating responses that error out.

1 Like

The team should be working on this persistent issue. This ought to be a priority high on the list of bugs to work out. I do hope they fix the issue in a timely manner so we can all use the platform’s functionality that we paid for.

I signed up just today to take advantage of the ability of the plugin to browse the internet but it’s left me feeling like a bait and switch has been done on me. I do hope this isn’t the case and that the team can address this issue soon.


Yea I am running into this exact same issue. The problem likely lies in the programme running into website robot.txt files that are there to stop bots from accessing sites and presenting false traffic, to safeguard the websites monetary value. OpenAI need to work out how to get around this in an equitable way for website owners and the end user.

1 Like

Yup. having the same issues. It’s intermittent and I suspect tied either to specific websites or content length on page. Would be great if if provided more info as to why the error is occurring.

Same issue here. Responding so that I can get any updates on if there is a workaround or fix.

I have met the issues so many times. Is there anyone could provide a good solution to work it out?

Is anyone fixing this? Or is there other alternatives for better plugins?

+1 … wasn’t this supposed to help OpenAI catch Bard wrt realtime browsing of content…? am I doing it wrong…?

Well, I finally found a guy explaining the right solution on YouTube which worked for me. I hope it will work for all the people having this problem. Here it is: How To Fix "Reading Content Failed" Error in ChatGPT in ONE SIMPLE STEP - YouTube

Yes, this honouring the robot.txt file makes the Bing interface a bit of a nothing burger. I just try to have an article on science dot org read and summarized, and I got the expected response because of this. Not sure what to suggest as a solution, but just logging this in case the developers of this interface are listening.