GPT4 not browsing the web or is very reluctant to do so

Lately GPT4 seems to not want to browse the web. In most cases it says it’s due to a website restriction. Then after pressing it a bit this came out just a few minutes ago:

“I’m currently unable to directly browse websites or access external content in real time. My capabilities are designed to provide information based on a mixture of pre-existing knowledge up to my last update and tools that simulate web browsing under certain conditions.”

What’s up with this?

5 Likes

I just tested and it worked fine on my end. In this case it even navigated automatically to the primary source of information, i.e. the SEC website instead of just doing a Bing news search (yes, the most recent news is a bit of an irony in this context).

Is there a pattern as to when you experience these issues?

image

2 Likes

I also tried the same prompt above on my end, and it worked.

Providing a direct link to ChatGPT-4 and requesting access often fails (possibly due to a robot.txt setting that prevents web access from ChatGPT).

It might be safer to assume that ChatGPT-4’s browsing feature is primarily limited to searching.

5 Likes

This is a stellar piece of information. I did some further testing.
See those two chats:

Search testing: https://chat.openai.com/share/e/ec18db45-4729-417e-995d-c88e16b8f875
Direct link testing: https://chat.openai.com/share/e/cfa4f7e3-92bb-4a5d-b5fc-e86571199c52

Notice how in Search Testing it CAN access and read (or already did read) the page and could provide the exact recipe. When fed the link directly it refuses. So maybe we can assume that it works, but only for links it found itself. Which is kind of pointless because it’s nothing more than a search engine that way. You can’t use GPT4 for summarization, page search, fact checking, etc. anymore.

This is what GPT said when I asked it about this fact:
“When you provide me with a link directly and ask me to read content from it, I’m unable to do so because I can’t open or interpret web pages directly from links given to me in the conversation. However, when I perform a web search using the browser tool and select pages based on the search results, I can access and summarize information from those pages. This process allows me to retrieve and share information from the web in real time, provided I initiate the search and select the pages myself through the browser tool. It’s a nuanced difference but important in how I can access and provide information!”

Also the robots.txt is almost never the issue. For example amazon forbids GPTbots but ChatGPT is “Chatgpt-User” as stated in the OpenAI documentation and “chatgpt-user” isn’t listed in amazons robots.txt, so it should work. But it doesn’t.

3 Likes

I have once just for testing purposes tried to give a custom GPT a set of links and asked it to access certain information from these websites. I believe in nearly all cases it did refuse to directly visit the site and would revert to Bing search and then access links based on the returned search results.

So yes, I think in general this seems to be the way it works. If the search query is specific enough it should be able to navigate to the site in question but it can’t be assured as it also depends on how the pages are indexed.

1 Like

I’m unable to access the link you’ve shared from my end.
Could it be that it was generated from a team plan account?
Links created under such accounts can only be shared amongst team members.

1 Like

Anybody from OpenAI care to comment on this? I’m seeing the same results and it’s very frustrating.

2 Likes

I also have not been able to access the web browsing feature (which was a massive part of why I bought gpt-4) and it’s becoming very frustrating. In the “my plan” tab it shows that web browsing is a capability included. Yet when I try and have it do something as simple as find free access articles on (insert topic) it refuses to. Hoping someone from open AI can respond to this thread.

1 Like

Once everyone has paid, they lower the performance to the point of rendering it useless in an attempt to make you spend your credits and reach the 40 messages/hour limit more quickly. Which forces you to pay a more expensive subscription.

1 Like

Still waiting for answers this is beyond frustrating.

2 Likes

Same here:

1 Like

April 2024 and GPT4 still gives the answer, “I can’t access the internet.”

Many weeks for me. No browsing at all no matter how i ask or request it.

1 Like

Just change to Gemini. Don’t let loyalty impact your productivity.

Are you kidding? Gemini is worse. It’s practically a joke.

The thread is about we browsing. I think everyone agrees that Gemini is significantly better at web browsing that chatGPT.

I’m just a user testing and studying GPT4 in a various way. I also found it is very limited. I’m waiting for their announcement

Its the same thing for me and is extremely frustrating as I use it heavily in my workflow :frowning:

This has been working so far:

Can you browse a specific webpage if I give you the link and provide me with a description of the services provided by the business of the webpage?

It will then proceed to ask you for the link and do the task.

Hey everybody,

I created my GPT a few months ago, internet browsing is checked in my settings but GPT tells me that it does not have internet access.
did you have this too? sometimes he makes you believe that he has access but when you ask him he answers: no!