No free credit in user's account

Today, one of the users of my web service was trying to create his own account; however, when he created his account, the amount of free credit which should be stored in his account is $18, but he found $0

I ran a cURL to see what was going on. Here is the script, he shared me his API key for debugging this.

curl \
  -H 'Content-Type: application/json' \
  -H 'Authorization: Bearer his_api_key_removed_by_me' \
  -d '{
  "model": "text-davinci-003",
  "prompt": "Say this is a test",
  "max_tokens": 7,
  "temperature": 0

This was the output. It seems that the $0 denominator may have had an effect on his account because of the quota, but why is this $0?

    "error": {
        "message": "You exceeded your current quota, please check your plan and billing details.",
        "type": "insufficient_quota",
        "param": null,
        "code": null

Help would be appreciated. Thanks!

We have the same issue.
It seems that we tried signing up to an account on a device that had already set up an account on another email. The new account credits were merged with the previous account.

Because this is a personal account, we’re now unsure whether to proceed with a paid plan if it’s going to interfere with billing.

Check with your client to see if they have already signed up on another account.

Same here. It is possible that I went through the setup process twice, but only because my Google login took me there.

I eventually had the issue solved. The user entered a wrong mobile number for verwhich we believed was used already.