Is anyone else suddenly lacking keyboard scrolling (PGUP/PGDN/HOME/END)?

I used to be able to scroll my chat with the keyboard, but it seems specifically ChatGPT4 is hindering this in my browser (Vivaldi/Chrome), because it works as normal for all other tabs and windows.

4 Likes

I can’t say I have tried before, but it isn’t working in Chrome.

Yep, the same issue here.

What I found - it is related to attachment button.

chats without attachments work just fine.

Good to hear I’m not alone, I’ve found other threads like this as well. Will examine about the attachment button, as far as I know it’s only available for GPT4+ (subscription), so if you run 3.5 you don’t have it.

I find the same behavior as you do, it doesn’t work for 4, but 3.5 works.

  1. I didn’t experience this previously (last fall or so)

  2. I haven’t made any changes to my browser

  3. I have tried Vivaldi/Chrome, Firefox, and experienced that same issue whereas previously not

1 Like

are you on subscription model ? like 20$ a month?

I also see a scrolling problem, on both a Chromebook, and on up-to-date Chrome Beta on Ubuntu 22.04. Shortly after ChatGPT-4 starts responding, my ability to scroll the web page stops. I have to reload the page to even see the whole answer, or sometimes it just throws away the question and answer. Very frustrating!

Hey folks!

I managed to fix the issue (funny - with the help of ChatGPT)

I’ve added the script to greasefork.
search greasefork for it by “chatgpt yaremchuk”.
(I can’t post links here for some reason)

details on installation can be found on greasemonkey home page.

Let me know if any issues.

2 Likes

This issue is very frustrating, so I’ve spent some time investigating potential solutions. Here are two workarounds:

  1. Press Tab: This key moves the focus to the next focusable element in the browser, typically the “Share” button or other interactive elements below ChatGPT responses (such as “Copy code,” “Read aloud,” or “Copy”). Since these elements are part of the chat panel, focusing on them allows the panel to regain focus and enables keyboard scrolling.

  2. Press Control + “/” (twice) or Control + “/” followed by Escape: This sequence opens the “Keyboard Shortcuts” popup, which captures the focus. Closing this popup by pressing Escape or pressing Control + “/” again shifts the focus back to the chat panel, allowing keyboard scrolling.

It appears that the chat panel needs to be explicitly focused in the browser to enable scrolling. Interestingly, clicking on the text or highlighting it within the chat panel causes it to lose focus, which is contrary to typical behavior—this seems to be a bug in ChatGPT4.

While this issue remains unresolved, I hope these workarounds help.

[And yes, my response was enhanced using ChatGPT, in case you notice any sophisticated terminology.]

2 Likes

Holy crap dude! I’ve wrestling endlessly with this problem with no help, especially from OpenAI customer service. But your fix worked! Thank you SO much.