Invited to try GPT-4, but don't have permission

Today I received the invitation to use GPT-4. Unfortunately, I lost my original API key, so I created a new one. However, when I try to access the models using the Python API (i.e., entering organization and API key and then doing openai.Model.list()) gpt-4 and gpt-4-0314 show all permissions set to false. Was the access granted only for the API key I lost? Do I have to join the waitlist again? :disappointed_relieved:
When I try to use the API, I get the RateLimitError, even though I’ve never used the API before.

Thank you


You will still be able to consume the GPT-4 via API, the permissions object lists permissions for obtaining embeddings, fine-tuning, etc.

I have similar permissions.

1 Like

Thank you for the reply. But if I try completion = openai.Completion.create(model='gpt-4', prompt='Hello World') after setting up the organization and api_key parameters, I get openai.error.RateLimitError: You exceeded your current quota, please check your plan and billing details. So it looks like I can’t use the model.

1 Like

I got the same problem. Doesnt remember me as Beta tester. Normally we should also get permission for the playground?

The gpt-4 model can be consumed only using the Chat Completions endpoint
cc @n_dittmann

1 Like

Yes you can access it within playground as well iff you switch to chat mode using the drop-down.

Also, I would like to remind you that sharing your keys is against the OpenAI terms of use.

And I’m not OpenAI staff.

Hi @Sergio814 I don’t think your GPT-4 access is bound to that specific API key, try creating another API key, it works for me.
Also as @sps mentioned, you could access through playground mode, although the max length is set to 2048 (probably needs an update when user specifies gpt-4)

Hello, thank you for the replies. I already tried creating a new API key several times, but I still get the RateLimitError. I get the same error in the playground.

Well, are you rate limited maybe? You can only do 25 responses over a 3 hours window, so maybe that is the problem.

@SomeUser2022 My usage history shows 0 requests since I created my account last year. I haven’t used the API before.

This is happening to me also, I made a new API key and its still not working