I can't login to my account using password

Hello,
I sign up using the option “continue using Google”, and I tried to find a spot where I can establish a password for my account, but I couldn’t. I tried to change my password using ‘forgot password,’ but after creating a new password, I received the following error message:

You tried signing in as “moad.odat@gmail.com” using a password, which is not the authentication method you used during sign-up. Try again using the authentication method you used during sign up. (error=identity_provider_mismatch)

3 Likes

If you have a question specific to your account, please visit https://help.openai.com

2 Likes

Hi @moad.odat,

this is because you don’t have a password when you use the single sign on because the authentication is handled by your google account.

Single sign-on (SSO) is a technology which combines several different application login screens into one. With SSO, a user only has to enter their login credentials (username, password, etc.) one time on a single page to access all of their SaaS applications.
Taken from What is SSO? | How single sign-on works | Cloudflare

Also a good explaination would be this video: Authentication fundamentals: Web single sign-on | Azure Active Directory - YouTube

It’s regarding Azure but the technology is basically the same.

Hi llinus,
Thanks for the explanation. I just want to create a password right now but there is no way on the platform to do it

1 Like

Hi PaulBellow, It’s about my subscription, not the API account

1 Like

Hi if you want to be able to set up a passwort there is (at least to my knowledge) no other way to set up a new account by using E-Mail because it is not possible to set a passwort when using SSO.

Found a screenshot as proof:
image

I had the same issue but went back to the sign on screen and logged on using my google account which turns out was the method I first used on the system !

I too was extremely frustrated by this login issue but finally I found a guy on youtube explaining the right solution and now I got logged into my ChatGPT account easily. Hope it works for all of the people. Here it is: ChatGPT: "You Tried Signing in As via Google, which is not the authentication method..." Fix Login - YouTube

I also want to change the authentication method, but I could not find the way.

This is insane. I have two accounts (personal and business), both using google SSO.
Now, I am logged in with my personal one. It is impossible to login with my business account (without hacking my way around it).

Whenever I try to login using google SSO, I don’t get to choose which account, no matter how many times I sign out, clear cookies and whatnot.

That’s the only place I have this issue. I have to sign out from my personal gmail account to be able to sign-in with the other or use a private window.

If I knew this beforehand, I would have just used username and password, but that ship has sailed now, with the current state of affairs.