Hyperlinks in Custom GPT not linking?

This problem still persists for us as well. However, it isn’t consistent. Sometimes the links work, other times they don’t. One of my GPTs always shows working links. The other is inconsistent.

Regardless, it’s very much still an issue.

1 Like

The team is actively working on this! Stay tuned.

3 Likes

We really appreciate that! Thank you for response!

1 Like

I think it’s a matter of the code
first I tried with below but it doesn’t work at all

[Text]('https://www.google.com')

but when I tried this, it worked!

[Text](https://www.google.com/)

I don’t know precise reason for this but it worked well for me.

Still doesn’t work. @AIdeveloper was spot on with the hyperlink syntax issue, which is likely on the OpenAI side of things, rather than an incorrect prompt on our end.

I have the same issue as well with highlighted unclickable link text in the GPT’s responses.

Any updates on this?
We have more than 50k Chats on our GPT called Scispace

Since links are not working, all the users are upset about it.

While its working for some other GPTs by other companies.

Thank you

3 Likes

Hey Logan, any news? My experience is it is working on links that are short. But if over 15ish characters, links don’t work.

1 Like

I still have same problem. tried all fixes in comments still same.
Friday, January 12, 2024 11:50:13 PM

2 Likes

I have the same problem. I tried several prompts but finally gave up.

1 Like

I had the same problem. The solution is: A customGPT cannot display clickable links or even images from a URL if this information is contained in the uploaded knowledge. Instead, it works if you write these URLs and the rules for when they should be displayed directly in the instructions. The instructions are limited to a certain number of characters, but you can also outsource longer instructions to a file in the knowledge and refer to this file in the instructions.

2 Likes

Unfortunately, after much testing, I came to this page and I was only able to verify this. We have to use part of our instructions to put URL links.

What I notice is that if the GPT uses “Searching my knowledge”, the URLs embedded in .md document comes off fine and clickable, but if the GPT decides to use code interpreter, the URLs embedded in .md document gets cut off sometimes (it seems the long ones, or the words after .com or domain that are natural languages such as “sharing” gets cut off).

I found it almost impossible to block GPT from using code interpreter - its behavior is just beyond our control which is not ideal.

So the only workaround I found so far, is using custom instructions as mentioned above. I am using other approaches mentioned above, will update if I find any success.

3 Likes

I am struggling with this as well. No set of instructions seems to fix this and at best the links only become clickable 10% of the time an output is provided or less.

It has been working for me perfectly for a while.

If you have the problem and are a developer, you may run the “Preview” mode and copy/paste the request and response JSON objects here for us to see.

Updated on 2024-02-02

The problem is indeed back in one case: URL in JSON in Knowledge.

Where can I find the JSON objects? In “Preview” mode I have a normal chat window.

Hey folks, thanks for flagging this. We have resolved a few issues around generation URL’s. There are a few known edge cases that don’t work well:

  1. Having the model construct full URL’s on the fly (you should instead pass the full URL back in an Action response)
  2. Having the model fill in URL details (same as above, you should pass in the full URL and all UTM parameters)
1 Like

I tested 3 cases (URLs in JSON and free text from actions, URLs in JSON in Knowledge ) and all worked around Jan 8.

Now it seems a new bug has been introduced somehow and it fails the third case. Here is a very simple test case. It may help the OpenAI dev team.

{
    "2294472375_24a3b8ef46_o.jpg": {
        "URL": "https://whatever.com/textures/2294472375_24a3b8ef46_o.jpg"
    }
}
  1. Upload this simple JSON to “Knowledge”
  2. Prompt to show it
  3. Observe the URL won’t be clickable because of the incorrect HTML a tag syntax.

Updates 2024-02-05

This particular problem has been fixed.

Unfortunately, however, the general problem still exists. When, the JSON file is slightly bigger, URLs are still wrong.

Links that are created directly by ChatGPT still don’t work. E.g. this prompt:

Display only a Google Calendar link to create an event "Test" on March 1st 12pm with a duration of one hour. No explanations, only the link.

It shows a link and highlights it but the link is not clickable.

1 Like

I have this same problem, for about a month now, very frustrating, links show in blue, but are not clickable, problem happening in Chrome and Edge also, I have not tried using other browsers, but not working neither in Chrome or Edge is already a big deal - because they used to work a while ago

I’m experiencing this issue on almost every plugin that is supposed to route me to a separate app or web page. Any update on the bug or the workarounds??