Hyperlinks in Custom GPT not linking?

Anyone else seeing this?

In my Custom GPT (WebGPT), when ChatGPT writes out markdown-linked hyperlinks, they aren’t clickable for some reason. They’re highlighted in blue, and when I hover over them, they change color (suggesting they’re indeed hyperlinks), but on Desktop they aren’t clickable:

On Mobile, they aren’t tappable either. They change color again, but don’t actually open the new page.



Hi, Just curious if you found a solution to it. I saw a similar issue too.

No, I have not found a solution as as of yet unfortunately.

1 Like

This is happening with our GPT too: https://chat.openai.com/g/g-bo0FiWLY7-researchgpt

1 Like

Hey @christian-salem how do you get this button to appear?

Mine requires you to confirm every time.

1 Like

I also confirm the problem, which was introduced just a few days ago.

The GPT framework actually gets the URL information from your GPT, and even attempts to format it to a nice hyperlink. Unfortunately, however, the newly introduced bug produces a wrong link like this:

<a target="_new">Visit example.com</a>

The correct syntax should be this:

<a target="_new" href="https://example.com">Visit example.com</a>


I have the same issue, but it reproduce it also with ChatGPT, not custom ones.

With some links, to google for example it works, but not with others. I tried in the android app and it worked.

Could be a conversation filter?

I have the same problem too. Also I can not display qr code that’s generated on my api services. I guess this problem is related to the same source. I can not reproduce the problem on mobile GPT app and can reproduce it on web version. The problem started from yesterday. I didn’t have it 2 days ago.

I pinged the team on this, will follow up when I have more details!


I just tested it and the problem has been fixed.

Thanks, @logankilpatrick


The problem has been fixed when other people use your GPT. But, as a developer previewing your own GPT during editing, you will still see the problem. Incidentally, when that happens, you will see a massive flush of errors in the browser console.

@adb @fjdelarubia @belsandre @JD_2020

Could you please kindly confirm my observations?

Updates 2024-01-07

The problem has been fixed finally.

1 Like

I can still see the bug posted by @JD_2020. The issue is not resolved.

1 Like

I’ve just tested and seems to be fixed, at least for my custom GPT.


I have the same problem with my custom GPT

1 Like

Indeed, the problem is only partially fixed. See my updates above. Thanks for raising the issue.

I still have the same problem with my custom GPT.

I have this problem with my GPT as well.

@logankilpatrick Is this something that’ll be fixed prior to launching the store?

This issue breaks all GPTs that link to external sites.

Did you see my updates above?

The problem has already been fixed.

I’ve experienced this issue several times over the past two days on my own GPT.

It seems this problem still present. The href removed from tag. Even I see during the generation (writing) ChatGPT inserts the link.

I cannot test with other Plus account, but it’s unlikely that the bug is present only for the developers.