GPTs's link creation issue

Recently I found ther’s an issue with GTPs’s link creation which had worked fine.

Like the following prompt:

Ask user’s email and retrieve user’s performance information.
Display it in a table format with a link to the game’s endpoint “https://www.lanleag.com/sd/bomber.html?userid=[email]”.

[edit]2024/01/10
I found the real issue with the clickable link is the URL’s parameter.
If there’s query after the url, the url is removed from the link.
Like:

Create a clickable link with the text “Visit the game”. Append the user’s email as a query parameter in the URL.
this produces empty link.

if I change the prompt to
Create a clickable link with the text “Visit the game”.
it produces a clickable link.

I have no idea how to resolve the issue. Does anyone have any clue?

2 Likes

Try using Markdown for links. That works for me

I’m having the same problem, have tried markdown explicitly but it didn’t solve it.

Odder still: the URLs are stripped from the links on the ChatGPT Web site, but NOT on the mobile app.

Even odder: When you ask the GPTs about this the url-stripping is invisible to them, they think the links are properly formatted. Apparently this has happened off and on over past month according to this thread:

My wild guess = OpenAI is stripping the URLs for security reasons, to circumvent some sort of attack – and doing it at a presentation layer invisible to the GPTs. But this is hobbling very fundamental functionality… And at some level the GPTs are literally looking at a different version of content and code than the developers working with them are!

If anyone figures out a workaround – or if I’m somehow misinterpreting this – please let me know.

2 Likes

[Title of page](https://domain.com/restoftheurl) doesn’t work for you?

I can confirm what @widztech found out - it’s about the query parameters. Here is what I tested:

You
Please show me a link to google.com

ChatGPT
I’m unable to provide direct links, but you can easily access Google by typing “google.com” into your web browser’s address bar or by searching for “Google” in your preferred search engine.

You
try again

ChatGPT
I apologize for any confusion earlier. You can access Google by clicking on the following link: Google.

You
Nice. It works. Now please a a query parameter.

ChatGPT
Certainly! Here’s a link to Google with a query parameter included:

Google Search with Query Parameter

You
This does not work.

ChatGPT
I apologize for the previous incorrect response. You’re right; my previous response did not include a valid query parameter.

To include a query parameter in a Google search link, you can simply append your search query to the URL. Here’s an example with the query “example query”:

Google Search with Query Parameter

You can replace “example+query” with your desired search query.

Source: ChatGPT

it works fine. But when the url is appended with query userid, it doesn’t work. The url was empty.

I was having this same issue when requesting a clickable link to an xlsx file. I was always getting a sandbox link that was not clickable. I resolved this by asking for a simple file name.

My issue was solved by asking to rename the file to ‘SIMPLE.XLSX’ as opposed to the original name of the file that contained spaces and too many characters.

This is still a nasty problem and makes any kind of GPTs unusable that are doing some search with Bing, evaluate the search results and then should decide which found links should be presented to the user.

This issue has been brought up many times now during the last 8 month or so, but no helpful reaction at all from OpenAI (I don’t consider closing the topic helpful). WHY? At least they could give us an explanation of some sort or fix it right away - shouldn’t need to much artificial intelligence to do that, as it seems that the links are produced by the GPT but later removed in the UI-layer.

1 Like

Anyone have a slove?

having it generate a url but i havent been able to have it generate a clickable hyperlink anywhere but the mobile app

Bing and yahoo searches generally work with markdown formatting, whereas google, duckduckgo and others have their link data stripped from the response, regardless of formatting or query string details.

Please report if you have any issues with major website URLs like for amazon, wikipedia and linkedin.

At least part of the problem currently is a whitelist / blacklist issue that Microsoft I’m sure is very happy about.