Custom GPT Bug - Hyperlinks not clickable

It looks like hyperlinks produced by custom GPTs are not working. Here is my GPT which provides links to research papers: https://chat.openai.com/g/g-bo0FiWLY7-researchgpt.

However, I noticed that the Bing functionality with ChatGPT can still provide clickable links via its native citation format ["]. Do I need to move to this format? Anyone know how to correctly do this?

3 Likes

I tried to figure how to generate links in citation format couldnt find a solution. Do you know how to generate citation format?

I tried my GPTs that recommend and include hyperlinks and they are still working for me. I tested yours, and the links did not work as you pointed out. There may be an issue in the way the output is structured in your instructions. I asked your GPT to remove titles and provide full URLs only. I was able to link to the referenced pages that way, but through copy and paste as opposed to click. I DM’d you the chat link if you want to check it out.

1 Like

What was your prompt that includes hyperlinks that are still working?

2 Likes

The prompt used on your GPT after requesting research links for a random topic was:

“Do not create a title for these links and instead list the entire url.”

This listed the entire URL and I was able to select it and link through to the recommended summary, but was not able to simply click it and be linked through.

When I referenced hyperlinks still working above, I was referencing my GPTs and not any specific prompt used on your research GPT.

The below, as an example, is a character builder GPT that will link a user out to create visual representations of characters they created. Links generated by it are clickable and working for me.

https://chat.openai.com/g/g-Impe1Ay0j

1 Like

It looks that it is ChatGPT GUI, not the GPT will remove any external links when generating the response html. The GPT could output the correct mark down content in fact. I tried if only using the openai link, it works very well.

I do not think this change is good for use experience, which cause a worse experience. I would strongly suggest revert to previous version and do not filtering out the none openai links.

2 Likes

Started experiencing this a few hours ago in Custom GPT.
Was able to reproduce the behavior with GPT4 chat as well.

Reproducible by asking GPT-4 the following:
generate a handful of sample links to wikipedia articles, use markdown

1 Like

My public GPT depends on the user clicking a link to download data. This needs to be fixed.

Update: Links still don’t work. Tested with a separate ChatGPT Plus account as well. I really hope this is fixed. I was just about to publish a blog post about my now broken GPT. :pray:

2 Likes

My actions with the same action which worked fine,does not works now.
Before it could generate the correct link to the external points.
Now it generates an empty link without any exrtrnal points.

having the same issue, my gpt using markdown syntax dealing all my url (link&image), and failed to function

1 Like

Same problem here, didn’t touch the GPTs for 2 weeks and when testing it today, the link wasn’t clickable.

1 Like

Yep it’s the same problem for me. It show the correct website link from my excel spreadsheet, however it is not clickable.

1 Like

Yup, even when asking for markdown with exact instructions it cannot do simple task. Also when asking to retrieve links for spreadsheet in the knowledgebase, it is hallucinating and creating its own links.

1 Like

They seem to be dealing with some exploits (mostly relating to images) so, bumpy ride folks.

You’ll notice that all links now go through a safe_url check. May be a whitelist.

4 Likes

Hi, I experienced the same thing today and it is becoming very annoying. I just wanted the user to be able to go to my website at some point to share data. I would like you to do something about this problem.

1 Like

I have the same issue with the empty links, too.

I might have isolated the issue. I found that complicated links that contain characters like `,<,>,(,) are more likely to not be clickable. I tried replacing them with the % encodings like %28 for ( and I was able to make some links clickable again but it was hit or miss.

1 Like

This is quite sad limitation that’s now introduced in ChatGPT UI, it severely limits the functionality of customGPTs, and also use of somewhat advanced prompts to generate rich content with images and links.
I have a custom GPT that would call external API that generates report, and provides link to that report in response (because the report is much larger than is possible to return via API call). Now the only option is to present the URL to the user, and ask them to copy/paste it in a new tab. That’s quite poor UX. Whatever caused OpenAI to introduce such drastic measure, this fix causes more harm than good.

First off, thanks for all that are reporting this.

For those that have reported this or for others reporting such can you include a link to the custom GPT and also a simple prompt that is not working. Include the text of URL that did not work for you and the expected URL if it not an hallucination. I would like to try them over the course of a few days.

I just tried a few custom GPTs and seem to be getting all clickable links. As I don’t know if OpenAI fixed this curious to see if this is consistently reproducible.

Here are 2 of my GPTs that produce links (even though I have others as well that produce links)

Please check as it seems to show as a link but the link is not ckick-able.

1 Like