GPT-4 Model Does Not Exist

Hello, I understand that GPT-4 is available to everyone. I am using Python to access the model. Python has been working well for me with the GPT-3.5 models, including the new 16K model. But, when I try gpt-4, I get the following error:

openai.error.InvalidRequestError: The model: gpt-4 does not exist

I also tried gpt-4-0613 because I saw that somewhere as the appropriate model name to use.

I tried generating another key. But, that did not help either.

Thanks!
James

1 Like

Welcome to the forum!

GPT-4 API access is being rolled out to everyone this month, if you have not had an API bill before then you may need to wait for the end of the month, if you have had a bill before then you should have access over the next few days.

1 Like

Do you have access to GPT4 in the playground? if not you don’t have access yet.

2 Likes

Thanks of the sanity check. I thought that would be the case, but I wasn’t sure.

Do you know about “gpt-4-32k” model? I now have access to “gpt-4” and the documentation also mentions “gpt-4-32k” but it returns model_not_found :sob:

The 32k model is still in very limited alpha testing, there is no official timeline for it’s rollout. The compute requirements are very high and with all of the GPT-4 8k rollout going on I don’t expect 32k to be anytime soon.

1 Like

Seems like gpt-4 access was working for me a day or so ago, and has since been revoked (I no longer have access)?

It is entirely possible that GPT-4 showed in your list of models for a brief period while updates were being performed, but unless you have received an email telling you that you have been granted access that is not the case.

All developers will have access by the end of the month, if you have paid at least 1 API bill then you should get access this week.

Thanks, everyone! I will be continue to be patient, I guess. I have been on the waiting list since February. :slight_smile:

Heh, it is the same for me. I have been paid developer for several months but still didn’t receive GPT4 API access (requested access long before and with current news fascinated to try it now). Hope will receive it in the upcoming days.

Guys, here is how you can check your access with API key:

@Foxalabs, by the way, should I regenerate the API key?

I remember when I started to pay for the service I had to update my API key, cause it was restricted to free-tier requests per minute (RPM), and the issue was fixed (RPM became 3.5K) only after generating a new API key.

You can certainly try generating a new key, costs nothing. Otherwise you’ll just need to be patient, they said all developers will have access by end of month.

1 Like

He, like many of users Im wondering why I can not access to gpt-4 models.
I’m a paid user for a long time and I have access to the gpt-4 playground.
I have updated my key already…

Do you have other tricks ?
thank you

You will have access by the end of the month, if you have already paid at least one API bill that has has resulted in money being taken from your bank account you should have access in the next few days.

I also joined waitlist months ago but got no access, now waiting for this rolling out lol.

When will I have paid an API bill? I’ve only accumulated about $7 worth of usage over 2.5 months, and OpenAI has yet to actually charge me. Do they wait until you hit $10-20 before sending the first bill?

To get the list of gpt models available to you:

import openai
openai.api_key = '***'

models = dict(openai.Model.list())
print(sorted([ i['id'] for i in models['data'] if i['id'].startswith('gpt') ]))
3 Likes

I just upgraded one of my accounts to plus a few days ago, will I also be getting GPT4 API access in the next few days??

Welcome to the forum!

You should get access by the end of the month.

1 Like

You should be all set now @Emergent

+1 to what @Foxalabs said, we are not granting wide access to 32k GPT-4 right now.

@jrh613 you don’t have access because there is no spend on your account right now, we are opening GPT-4 up to everyone at the end of the month so stay tuned!

@artem.sukhliak your account did not have a paid invoice which is why there was no access granted.

@antoine1162 the min payment to get access was $1 and you were below that threshold.

@bobartig checking this, not sure off the top of my head. Will update the dev portal to say this.

@FAFA at the end of the month likely. We batch granted access to people who had a successful bill paid on the day we announced this but are not actively adding more folks until EOM.

1 Like