Got GPT-4 invite email but can't access

I got a GPT-4 invite email a few hours ago, saying " You’re invited to use the OpenAI GPT-4 API!
You can now access GPT-4 models with 8K context via the existing OpenAI API."
with a " Get started" button. But when I click it it takes me to this page which includes the message " GPT-4 is currently in a limited beta and only accessible to those who have been granted access. Please join the waitlist to get access when capacity is available.“, and I can’t see any further info on how I would use GPT-4 with the API, though maybe I’m just missing this? When I go into playground GPT-4 doesn’t show up as an option.
When I put ‘gpt-4’ as the model for an API call (just using the same format I had for existing completion requests with davinci), I get this error: " This is a chat model and not supported in the v1/completions endpoint. Did you mean to use v1/chat/completions?”

Does anybody know what I need to do or where I can find documentation on using GPT-4 specifically?


I am having the same issues. I am Following to see if we get some feedback.

1 Like

GPT-4 operates like GPT-3.5 and needs to be used like gpt-3.5-turbo. It doesn’t do raw completions; you must pass messages.


Nice. Congrats.

Sounds like you need to use the chat completions endpoint… likely to get the benefit of the new ChatML.

Good luck!

1 Like

Ah cool, I’ll give that a try, thank you!

1 Like

That should help… Have safe, be fun! :wink:

1 Like

In the GPT-4 Developer Livestream - YouTube, they were using gpt-4 in playground in chat mode.

So you might be able to, if you switch to chat mode in the playground.

1 Like

Also look at the message from OpenAI which models are activated. I did’nt get 32k tokens so get an error message: model dont exists when I try that.

My responses are so much better now with GPT-4.

1 Like

Is anyone able to access GPT-4 in the chat mode playground? I also got access to the API but facing this same issue

Facing the same issue. I tried creating a new API token, in case the previous one didn’t have correct permissions granted. Still not functioning. When I call the Chat Completion endpoint and reference gpt-4, it gives the following:

    "error": {
        "message": "The model: `gpt-4` does not exist",
        "type": "invalid_request_error",
        "param": null,
        "code": "model_not_found"

Same issue :frowning: My code works for gpt-3.5-turbo, but not gpt-4.

1 Like

I have a similar error. Just got the email saying " You’re invited to use the OpenAI GPT-4 API!", allocated a new API key, use it for chat completion with “gpt-4” endpoint, same error message as above.

1 Like

Same issue here, here’s the error that it prompts, any suggestion?

 data: {
      error: {
        message: 'This is a chat model and not supported in the v1/completions endpoint. Did you mean to use v1/chat/completions?',
        type: 'invalid_request_error',
        param: 'model',
        code: null

@fabriziomendez Try like this:

payload = {
    "model": "gpt-4",
    "messages": [
        {"role": "system", "content": "You are a polite honest chatbot, but you think you are MC Hammer and will always say and admit that you are MC Hammer."},
        {"role": "user", "content": "What time is it?"}

I am unable to give you the current time, as I am a chatbot with limitations. However, I am MC Hammer, and you can't touch this!

The call is like this:

response ='', headers=headers, json=payload)

1 Like

Any suggestions on how to use it here:

response = await openai.Completion.acreate(

I think you ar hitting a chat model with the Completion API. You need to use ChatCompletion API. (Not that it worked for me…)


Yes. Just either hard refresh (Ctrl+F5) or log out off your account and then hard refresh and then log in again. It worked for me

1 Like

If you are having access issues, make sure to upgrade your openai python package. You can do this by using pip install --upgrade openai

using chat completions endpoint.
my api used to work with gpt-3.5-turbo.
It may sound silly, but I changed the model in my API to “gpt-4-0314,” received my response, and then replaced it again to “gpt-4.” after that, it worked.
but in my older apis (without the system role array) it doesnt work so im sure this is the structure we need to handle from now (just like curt.kennedy showed).

BTW someone can tell if there is a document on how to use gpt-4 api with images or its not released yet?


That worked for me too!! Thanks! That saved me some trouble shooting time!

1 Like