Cant find and use gpt-4 model ( I have the gpt-4 Invitation)

Got Gpt4 Invite but cant find it with openai python chatcompletion class.

response = openai.ChatCompletion.create(

Console: ERROR:root:The model: gpt-4 does not exist

GPT4 = ‘gpt-4-0314’
model = openai.Model(MODEL_NAME)

def list_all_models():
model_list = openai.Model.list()[‘data’]
model_ids = [x[‘id’] for x in model_list]

Console out:


Can you make sure that the account you were granted access on is the same account you are trying to make the request from?

1 Like

FYI, the email you are using for your account here on the community forum does not have GPT-4 access. Make sure you are using the right account.

Hey Logan,

thanks for, the quick response! Sorry, I have to clarify, I got a token from a friend. He got gpt-4 early access and sent me a token to let me make some tests in Gpt-4 for my coding bot I‘m currently developing.

Could this be the issue?

Can you help me check why this account cant uses the gpt-4 model?I also have the gpt-4 invitation

@logankilpatrick I’m also running into this issue. We got the email a few weeks ago saying we have access to GPT-4, but I’m not seeing it. We did change our organization’s name on the account after submitting our request, in case that matters.

I’ve tried reaching out to support, but haven’t had any response. Any help would be greatly appreciated.

@logankilpatrick I am having the same issue as well. I have a GPT-4 invite.

1 Like

I also have an invite for the GPT4 api, but I can’t access it anywhere: Not in chat, playground or API. I can see in the usage, that when I request GPT4 with the api (via Spreadsheet formula) it actually uses GPT3.5 turbo. What is going on? I would really like to use GPT4

1 Like

I have a plus plan subscription, but no access to gpt4 on playground. I have so many apps I wish I will test.

In case it helps, I learned that GPT-4 is only available through chat. Here’s what worked for me:

Direct Playground URL


curl \
  -H "Content-Type: application/json" \
  -H "Authorization: Bearer $OPENAI_API_KEY" \
  -d '{
    "model": "gpt-4",
    "messages": [{"role": "user", "content": "Hello!"}]

cc: @rrttrr0529 @pinaki

I have resolved this issue because I have two accounts on my computer, but when I applied, I filled in the organization number of the other account, so I now have to use the other account to call gpt-4

Hi all, I resolved the issue by generating new API Keys after getting the gpt-4 invite. Hope this helps!

1 Like

Did you get access to GPT4 for both chat and complete? I can only see the GPT4 under chat but not under complete. Thanks

Did you get access to GPT4 for both chat and complete? or it is supposed to be only for chat. Thanks

GPT3/4 are only available through chat API endpoints, not completion