Received invitation to GPT4 API but it is not available?

I received an invitation with the subject line “ Your GPT-4 API invite is here,” but when I try to access I am prompted to “join the waitlist.” Is there a technical glitch?


I had the same thing. Was just about to make the same post

I have the same issue. Not sure what happened. Is it based on organization or the email address?

Not sure what happened, but gpt-4 inferences run flawlessly now.

Is based on organization ID and on Playground can be found by switching to chat mode.

Getting the same, 404 for API requests after getting access. Is there anything special that needs to be done?

Same here I got 404 while using gpt-4 model. But I can see them when listing models with listModels

Yes same issue for me. Cant seem to be able to use it anywhere when accessing the API

I found a solution thanks to @cubs on discord

Use createChatCompletion instead of createCompletion

Before (not working):

const response = await openai.createCompletion({
    model: 'gpt-4',
    prompt: prompt,
    max_tokens: 50,
    n: 1,
    stop: null,
    temperature: 1,

After :

const response = await openai.createChatCompletion({
    model: 'gpt-4',
    messages: [{ role: "user", content: prompt }],
    max_tokens: 50,
    n: 1,
    stop: null,
    temperature: 1,

still i think there is an issue with openai.createCompletion as it should work also


Thank you, this solved it for me.

Thanks for sharing, i would assume that we can only use the chat options

Does anyone know if there is a way to add the best_of?

I have the same problem. Received an email saying that I have access to the GPT-4 API. When I go to my account, I still see a message telling me ‘sign up to the GPT-4 API waitlist’ and it seems I don’t have access.

Any advice?

Well, my advice is don’t feel too bad.

I am one of the most active tech guys here helping people, perhaps even the most active over the past week, month and quarter, and OpenAI does not seem to want me to help people with gpt-4 technical issues here. I have been on the waitlist and have no email welcoming me to gpt-4 either !!

So, my advice is to not feel too bad. You are not alone!

I modified my OpenAI Lab I use to help people daily, the first day (see below) gpt-4 was announced, but of course it gives an error since I’m not “approved”, just like you.



Appendix: Error: {“message”=>“The model: gpt-4 does not exist”…)

You are not alone.


This worked for me :point_down:
First open OpenAI API
Then change MODE in right hand panel to CHAT BETA
Then select GPT4 from the dropdown labeled MODEL.
You also get GPT4-0314 from the same dropdown

1 Like

Hey @ruby_coder is that OpenAI Lab available for anybody?

@ruby_coder your OpenAI Lab looks amazing! Is that open source by any chance?

Thanks! Yes, it is a great tool. I enjoyed coding it.

Is that open source by any chance?

No, I have not released it, sorry.

I wrote it to help devs here so I can test any function in the API as well as test embeddings and methods as well as having two chatbots, one for each API method.

I wrote it because, in my view, there were (and still are, in my view) too many people posting here looking for clients and/or driving people to their websites and YT channels v. really helping them here, in our community.

So I do not have any plans to release it, my apologies.


Is this code with C# and a NuGet package? I haven’t been able to get the NuGet packages to work with .NET 6

I was receiving the same error when accessing the API programatically - I solved it by generating a fresh API key

Thank you, this worked for me :pray: