Got GPT-4 invite email but can't access

Still doesn’t work.

  1. Upgraded to 0.27.2
  2. Created a new API key. Checked the username is the same as the username which got the invitation email from OpenAI.
  3. Went back to basics command line call:
curl \
  -H "Content-Type: application/json" \
  -H "Authorization: Bearer $OPENAI_API_KEY" \
  -d '{
     "model": "gpt-4",
     "messages": [{"role": "system", "content": "You are a polite chatbot."}
     ,{"role": "user", "content": "Say this is a test!"}],
     "temperature": 0.7
> > > > > > > > {
    "error": {
        "message": "The model: `gpt-4` does not exist",
        "type": "invalid_request_error",
        "param": null,
        "code": "model_not_found"

Any idea how you can access the gpt-4-32k 32k Context models?

I think they will prioritize the people who help out with their evals. But they will be awarding access slowly i believe

1 Like

Is it showing in Playground under Chat completions?

You were correct, thanks for your help. Here’s a simple code using your prompts to test the new model, worked fine!

import os
import openai
openai.api_key = os.getenv("OPENAI_API_KEY")

completion = openai.ChatCompletion.create(
    {"role": "system", "content": "You are a polite chatbot, but you think you are MC Hammer and will always say and admit that you are MC Hammer."},
    {"role": "user", "content": "What time is it?"}


“I apologize for not being able to give you the current time as I cannot access real-time information. However, I just want to remind you that it’s always Hammer time, because I’m MC Hammer! If you have any other questions, feel free to ask.”


1 Like

I had the same problem. I have two organizations: my personal org (the default) and a second one that I set up for developing with GPT. Because I have two organizations in my account, I had to send the organization identifier along with the API request. The GPT-4 invitation only applied to one of them!

Find your organization identifier here:

example using curl:

curl \
  -H "Authorization: Bearer $OPENAI_API_KEY" \
  -H "OpenAI-Organization: YOUR_ORG_ID_GOES_HERE"
1 Like

I was able to get it to work by adding my organization id to the headers. Does that help?

This worked for me :point_down:
First open OpenAI API
Then change MODE in right hand panel to CHAT BETA
Then select GPT4 from the dropdown labeled MODEL.
You also get GPT4-0314 from the same dropdown


Got the same issue over here. Any way I can reach support?

Had a similar problem. One solution that worked for me was to generate a new API key (one created after you got access) and implement the below Javascript:

const { Configuration, OpenAIApi } = require("openai");

  const configuration = new Configuration({
    apiKey: "<INSERT-API-KEY-HERE>",

  const openai = new OpenAIApi(configuration);

  const response = await openai.createChatCompletion({
    model: "gpt-4",
    messages: [
      { role: "system", content: "You are a helpful assistant." },
      { role: "user", content: "Who won the world series in 2020?" },
      { role: "assistant", content: "The Los Angeles Dodgers." },
      { role: "user", content: "Where was it played?" },
    max_tokens: 50,
    n: 1,
    stop: null,
    temperature: 1,


I found it can be hard asking it if it’s using model 4 or 3.5 turbo etc. Easiest way to check which version you’re using is to check your API usage requests.

Another thing to call out is that I’m unsure you can try GPT-4 for “free” so if you haven’t added a credit card yet, try doing so. It’s very cheap anyway.

Wrote a quick detailed guide here as well of how to do an API request using Javascript & Next.js to Chat GPT-4 - feel free to have a look at that one as well.