Getting message "Your rates are too low to run action" despite having purchased credits

I’m having issues with the OpenAi API key.

I purchased a balance over a week ago, and my account indicates that I have yet to use any of my available credits, but when I try to make an API call using Zapier or Clay .com, I’m getting the message below:

“The rate limits associated with your OpenAl APl key are too low to run this action with the selected model . See “Increasing your limits” here.”

I’ve been speaking to support, but they’ve been little / no help, having yet to resolve this, and taking 2 days between each response. I’ve also looked at 10+ community threads presenting similar problems, none of which present a solution. Where is customer support?!!

Steps Taken So Far:

  1. Verified rate limits and usage in the OpenAI account.
  2. Reviewed and confirmed correct usage and billing.
  3. Added additional credits to my account.
  4. Regenerated the API key.
  5. Contacted support multiple times with limited response and resolution.
1 Like

Welcome to the forum.

You can find more here. Might be on the cusp of 7 days?

You can view the rate and usage limits for your organization under the limits section of your account settings. As your usage of the OpenAI API and your spend on our API goes up, we automatically graduate you to the next usage tier. This usually results in an increase in rate limits across most models.

Tier Qualification Usage limits
Free User must be in an allowed geography $100 / month
Tier 1 $5 paid $100 / month
Tier 2 $50 paid and 7+ days since first successful payment $500 / month
Tier 3 $100 paid and 7+ days since first successful payment $1,000 / month
Tier 4 $250 paid and 14+ days since first successful payment $5,000 / month
Tier 5 $1,000 paid and 30+ days since first successful payment $50,000 / month

Select a tier below to view a high-level summary of rate limits per model.

#### Tier 2 rate limits

This is a high level summary and there are per-model exceptions to these limits (e.g. some legacy models or models with larger context windows have different rate limits). To view the exact rate limits per model for your account, visit the limits section of your account settings.

Model RPM TPM Batch Queue Limit
gpt-4o 5,000 450,000 1,350,000
gpt-4-turbo 5,000 450,000 1,350,000
gpt-4 5,000 40,000 200,000
gpt-3.5-turbo 3,500 80,000 400,000
text-embedding-3-large 5,000 1,000,000 20,000,000
text-embedding-3-small 5,000 1,000,000 20,000,000
text-embedding-ada-002 5,000 1,000,000 20,000,000
whisper-1 50 - -
tts-1 50 - -
tts-1-hd 5 - -
dall-e-2 50 img/min - -
dall-e-3 7 img/min - -

https://platform.openai.com/docs/guides/rate-limits/usage-tiers?context=tier-free

What are you trying to do? Embeddings? You might be hitting a RPM limit it sounds like?

ETA: I believe new API keys have permissions on a project level too, so maybe check that…

Also, what does the rate-limits page say you’re at right now?

@PaulBellow thanks for the quick reply. I’ve attached a screenshot of my rate limits plan. I’ve only spent between $15-$20, so based on the usage limits you shared, I should be in tier 1, and presumably shouldn’t have to wait for 7 days, correct?

1 Like

Right. If you click on the one link, it will (should) show you what tier they have you at currently, so you can compare that to what your usage logs show.

Then, if it has been more than the time period + money spent, you can go back to support with proof and say, this IS a bug because I’ve spent $XXX and wait X days, and I’ve not been increased as seen on this page (then screenshot your current tier…)

Again, it might be a timing thing too…

Thanks, I’ve confirmed from the link that I’m in Tier 1. The credits were purchased, invoiced, and made available on July 2 (according to screenshot) - however on the point re: timing, based on my tier these credits should already be available, yes?

1 Like

Right yes, but the error states “to run this action”… is it a simple call? To a model you have access to at Tier 1?

How I read it is that you need to spend $50+ and have had 7+ days… so you’ll need to spend more to get Tier 2…

I’d check your limits for Tier 1 more closely with what you’re trying to do exactly (or share prompts/models here)…

1 Like

I’ll go through the checklist

  • The table you’ve shared says “Tier 1 Qualification: $5 Paid”.
  • I have confirmed I’m Tier 1 access,
  • I’ve confirmed multiple payments.
  • It’s now been 9 days since any of this was done.
  • I’m still getting the same error (see attached)

I’m not sure what qualifies a “simple call” vs one that is not. But this is about the most basic API option that clay dot com possesses. My co-founder uses his API key with no issues in the same tier.
Screenshot 2024-07-11 at 5.05.20 PM

Yeah, I dunno then. Sorry.

If you’ve tried a new key with appropriate permissions, try to narrow down what your co-founder is doing different?

His account is pay-per-use, must be because he’s had this API for a long time.

I think I’ve checked about a dozen boxes in total. Support said they “couldn’t figure out what the problem is”, suggesting that I upgrade to the next tier in the hopes that it works.

This feels like a dead end, except I’m not asking for an enhancement or new feature. I just want to use the product at its most fundamental level.

Is this the support experience I should come to expect when trying to use an OpenAI product?