Failed to update assistant: UserError: Failed to index file: 'qdrant'

Attempting to upload a 6mb .txt file to a new assistant with retrieval enabled, and received the titled error after a delay.


I also have this same error, it’s a strange one. I think it was working earlier but now I’m not entirely sure.

I’m getting the same error with 8mb .MD files.

The problem goes away when I create a new Assistant, fyi!

Same here. But very weird, it uploaded all of my files except some random 1 file.
And still doesn’t want to upload it.

Failed to update assistant: UserError: Failed to index file: Error extracting text
from file file-3yoFxqE9ZD4gRl5Tk0oJ2Shy

Edit: After further investigation, it looks like there are still heavy limitations on the files you can upload and their contents. You’ll see the exact error message if you, instead of uploading your file, copy the contents of your file into the actual editor and send it. Have a look.

Hello! I’ve tried different file sizes using csv. Same thing.

workaround: paste your data directly while they fix it :fire:

New update: the problem is related to Retrieval functionality. If you disable it the error goes away…