"Failed to index file" in all Assistant API threads w/ uploads

For at least the past hour I’ve been unable to run any threads that have a file upload. This includes via the Playground and the API. All attempts result in Failed to index file. I’ve tried creating new assistants, changing assistants, etc. The failures are occurring on assistants I’ve had running for the past month, so it’s not a configuration issue.

Anyone else going through this right now?

1 Like

Update: this is only failing in one company account. I’ve tried a separate company account and it’s working just fine. The one it’s broken in has higher limits, more credit, and more history than the one that’s working. Please help, if anyone has any advice!

1 Like

We are experiencing the same issue with similar details (heavy usage account at max usage tier, assistants in use for month or more). Definitely interested if anyone has insight into the types of reasons this might happen.

1 Like

Going on to 8 hours of complete outage of all threads that have a file attached.

Support ticket has been filed for nearly the same amount of time. No acknowledgment of issue from OpenAI.

Any luck, @craigts ?

2 Likes

@matt33 Unfortunately no word on our account either. Hoping we can get this addressed for everyone quickly.

1 Like

I have a Tier 4 account, and managing over 25 assistants with files attached and using gpt-4-1106-review. All the assistants use Code Interpreter and my code is based on the Assistants API.

The degradation of performance in the last 48 hours is stunning. I’d say that half of the runs were failing, expiring or getting cancelled. Latency can be huge, sometimes up to a minute…per run!

Just imagine having a database on AWS with each simple SQL query taking a minute and with half of the queries unable to complete. We would cancel immediately!

I understand that it is a beta version but OpenAI needs also to understand that we are paying customers. We should expect some basic customer service here, with acknowledgement of the issues when they happen and a timeline for a resolution.

1 Like

Same here. Failed to index file error began occurring across multiple assistants around 6-7 pm EST on 02/08.

2 Likes

Hi folks, apologies for the issues here, we are actively investigating. Could you all share a bit more info with us?

  • Org ID / Assistant ID / File ID
  • Any request IDs from the failed requests
  • Example files that repro the issue

That would help us fasten our investigation. Thank you!

1 Like

@atty-openai Info posted above :arrow_heading_up:

Thanks Matt, we’ve begun to identify the issue and are working on a fix. Will keep you posted.

2 Likes

Thanks Craig, we’re working on the issue. Will keep you all posted.

Hi folks, we think we have a fix rolling out. Could you both confirm if you are still seeing the issue with indexing files in your affected orgs?

At least one of my threads is now indexing a file properly. So this is progress :+1:

EDIT: I can’t find any failures at this point. So it looks like your fix is good, @atty-openai

@atty-openai This thread is still not working: thread_C6jDci8FHfzQQwj0VzjrLCrA

Thank you! We think the issue is now resolved, but please let us know if you find issues again. You can also directly email me at atty@openai.com.

The root cause was a database job that had a small percent of errors on specific subsets of users, and your orgs were unfortunately in those subsets.

Sorry for the issues :frowning:

2 Likes

@matt23 thanks, looking into this one.

Do you have a file ID that you tried on that thread?

1 Like

Yes, @atty-openaifile-ETDWW30azB7ubhTJYMcZMJNG

I am back up and running it appears, but I am always creating new threads.

Also verified my threads with files attached are now working correctly, thanks!

Seems to be working for us as well. Thank you for the fix!