Extended Bug - File Upload Issue Playground

Note: This is an extension of thread due to no resolution found at: Failed to update assistant: UserError: Failed to index file: Unsupported file type: application/csv

Many file formats like .csv, .xlsx, .docx are failing to upload for most users.

  • Many approved file formats are bugging out on upload.
  • While formats such as .pdf are succeeding for most users. Assertion based on multiple community user posts.
  • .csv, .xlsx in my personal experience are failing to upload in assistant playground.

If you’ve solved this, please share detailed insights and your solution.

Else, if you’re facing a similar upload specific issue in playground; report your bug and scenario so @openai team can look into it hopefully.

Image below contains error faced during .xlsx upload.

  • Single sheet
  • Download from google sheets
  • Re-attempted via mac numbers app
  • UTF-8 Ensured

1 Like

I’ve also experienced the same with google spreadsheets.

I had a spreadsheet made by MS Office and that worked so I’m guessing something in the Sheets xlsx format that OpenAI doesn’t like. It’s hard to work out what it might be from that response though.

1 Like

Using the api I managed to fix this by opening and saving the file with the python library openpyxl before then uploading to OpenAI

1 Like

Thanks, let me give this a shot and get back.