Failed to update assistant: UserError: Failed to index file: Unsupported file type: application/csv

Via playground when uploading a file to assistant for retrieval. It appears the file itself is being uploaded fine since it shows up in the “files” tab but fails to update the assistant.


getting this same issue. I can’t even see the gpt 4 model in the dropdown and I’m a paying customer. Is there something i need to enable in order to get the gpt 4 model show up in the assistant api

same issue when creating an assitant
Screenshot 2023-11-06 at 10.04.13 PM

1 Like

I’m seeing this as well with the API when using a CSV and in the playground. Not finding anything in the docs that might remedy it, and it seems like an issue with the API itself.

same error when I create an assistant in the playground:

Failed to create assistant: UserError: Failed to index file: Unsupported file file-eiVO1HNrbJuegHxqTQSJIkSw type: application/csv

same error as everyone else, cant upload png or jpg, must be issue on openai side. Please fix it.

Same issue here as the others: can’t upload csv files of 10 lines

1 Like

Same Issue.
It’s something to do with the MIME Type
More on this at this link

What is correct content-type for excel files? - Stack Overflow

Same issue for me, i tried pretty much everything, tried 3.5 retrieval, tried removing custom instructions and tried creating new assistants. OpenAI please fix this.

1 Like

Same issue. I’ve found it working with csvs coming out of excels, though those coming out of GSheet and Jupiter don’t work. Maybe this is because of the excel default UTC 8 encoder. The issue is, it’s getting uploaded properly, but then the assistant must rework the file a lot, going through errors to cope with the UTC encoding. Am I right having doubts that the Code interpretor and Retrieval tools will provide worse results with pdfs than with csvs when it comes to analyzing data and providing recommendations?

Looks like Bug, something to do with the system expecting only JSONL file format.

If you go to Files tab of playground and try to upload from there, it only allows JSONL. However, even JSONL wont actually upload.

Also, the CSVs/PNG/etcs files are “Ready” but you get an error if you try to delete them.

Can get around it via API upload as a Temp solution.

Python -
from openai import OpenAI
import os
import dotenv

api_key = os.getenv(“OPENAI_API_KEY”)
if api_key is None:
raise ValueError(“The OPENAI_API_KEY environment variable is not set.”)

client = OpenAI(api_key=api_key)

file = client.files.create(
file=open(“put your file name here with file typ eat the end aka .csv”, “rb”),

assistant = client.beta.assistants.create(
name=“Enter your assistant name here”,
description=“blah blah blah, You are great at creating beautiful data visualizations. You analyze data present in .csv files, understand trends, and come up with data visualizations relevant to those trends. You also share a brief text summary of the trends observed.”,
tools=[{“type”: “code_interpreter”}],

Once this runs, you can go back to the playground GUI and will have the file and assistant.

1 Like

Same issue here. Can’t upload files to the assistant in the playground

Update: Looks like its actually specific to the Retrieval functionality. If you disable ‘Retrieval’, it works.
You can use Code Interpreter for Retrieval as a temp, less effective solution.


Having the same issue here. Subscribing to this thread


Same issue for me, with jpeg (via Assistant in Playground).

Turning off retrieval allows we to continue, but then uploading an image as a User returns the same error.

1 Like

Same issue. Unable to use Retrieval. Works with Retrieval turned off.

1 Like

Thank you, disabling Retrieval worked for me.

1 Like

Same here - .csv doesn’t work with retrieval turned on (and that’s what I want it for)

Same. Thank you, disabling Retrieval worked for me.

1 Like