Error saving draft when building a new GPT

i am able to upload files, only tried txt so far.

thank u. the problem seem to have been that i had 10 files (maximum). this is not clearly said anywhere. easy to miss

is it shure that this makes a problem? I uploaded about 30 pdfs and got also allways that message but it seems that the informations got trained anyhow, it means it looks like that it is not storing the pdfs but it is reading it before and learning with it.

Anybody can confirm what I think it looks like?

Would be interesting what experience do you have about it

Yea so frustraining when we spend hours building custom GPT’s and the cant be saved! Id expect this from the free version but for the amount we’re paying this is pretty poor effort.

I think I found the problem (At least helped me to figure out what was going on) The answer is: The limit of files you are able to upload. For some reason you can only upload 10 files, after that it’s gonna constantly appear “Error Saving draft”.

I’ve met the same error. There is a error info on F12 panel
and the payload is

    "instructions": "",
    "display": {
        "name": "Philosophy Mentor",
        "description": "",
        "profile_pic_id": "file-oOvV1rQEwSBRnvtFrIVKnO5m",
        "profile_picture_url": "",
        "welcome_message": "",
        "prompt_starters": []
    "tools": [
            "type": "dalle"
            "type": "python"
            "type": "browser"
    "files": [],
    "training_disabled": false

and the response is

{"detail":"No personal org found for user and none created."}

Anyone know how to deal with it?

is your bot retrieving from the files in that zipped folder properly?

Captura de pantalla 2023-11-22 a la(s) 12.04.58 a.m.

It’s not working ! Somebody knows what’s happening?

I have the same issue. Seems like the file upload can cause this problem. Once it has an error, it will never work. I have to create a new GPT to make it work.

1 Like

I don’t use the chat because it messes up the title description and conversation starters.

I’ve just noticed, after struggling for a few hours, that one of my actions was duplicated - deleted one and then was able to save just fine

Summary created by AI.

The users are facing multiple issues related to the GPT builder, predominantly centred around saving drafts and uploading files. Initially, avian and myownsiteprivate speculate that the errors could be related to an outage. max.schumacher suggests that the errors could be inconsistent and advises coming back to it later. Issues with uploading files and saving drafts persist, as reported by cryptojaz, filip.ges, mileshighclub, and acasareto. inside4ndroid.techsu, marco.ghislanzoni, and ivan.hernandez.cely also confirm experiencing these errors across various browsers. While GPTKatts claimed to be able to save their GPT, they also eventually joined the list of users struggling with the issues.

As a workaround to uploading errors, users share their strategies. Foxabilo and EricGT share links, while phillip2 suggests combining files into long PDFs, which xchris12 and Foo-Bar support and provide methods for text combining and splitting. Furthermore, aliamrohvi suggests attaching files in the ‘message’ section instead of the ‘Configure’ section, and Kaltovar recommends using Chrome as a browser for uploading files.

Despite the workarounds, general frustrations persist, as illustrated by aapostoliadis and TheBruno, who criticised the lack of clear communication regarding the issue. evansilberman and tommasopot raise questions about limits to file uploads, with the latter concluding that the maximum limit is 10 files. The conversation unravels a lack of clear guidelines, repeatedly leading to the ‘Error saving draft’ issue.

Summarized with AI on Nov 024 2023
AI used: gpt-4-32k

1 Like

@aliamrohvi - Can you expand on that?

From my custom GPT:
“Yes, if you upload files here, I can access and refer to their contents to assist you with your queries. However, it’s important to note that the files are only accessible within our current conversation. They are not saved to a permanent knowledge base or used in future interactions. Each session is unique, and previous files are not retained for future sessions.”

I was oddly able to add more than 10 files but couldn’t add more and it was really driving me mad. I took some of the previous advice in this thread and combined all of my docs into one pdf and uploaded them. Now I am able to successfully add in new documents to my custom GPT knowledge base.

I have been running into this over the last couple of days and finally decided to pop open the developer tools. Here is what the problem is for me: 400 (Bad Request)

And a little further down:

_app-468e21278b547784.js:26 Uncaught (in promise) FatalServerError: Cannot upload more than 10 files
    at _app-468e21278b547784.js:26:2078238
    at main-2c03450a19a7bc03.js:1:115276
    at (main-2c03450a19a7bc03.js:1:115381)
    at n (main-2c03450a19a7bc03.js:1:104807)
    at u (main-2c03450a19a7bc03.js:1:105004)

So, it is not that you can only upload 10 files at a time, you cannot upload more than 10 to a custom GPT. Time to merge those documents :slight_smile:

Indeed, The GPT knowledge can’t exceed 10 files.

So, I had ChatGPT write a Python script to merge my markdown files into one for uploading, and everything’s working fine now.

Not sure if there’s a total capacity limit for the knowledge, haven’t encountered any issues yet.

To fix this I had to find out the problem file by deleting one by one. I then reuploaded. The problem file might have got corrupted while it was trying to save maybe?

I was receiving this error well over 24 hours and it just wouldn’t save. I did have 11 documents added in the Config.
I removed one (so 10 max) and it saved straight away. Hopefully this will help others.