GPT changing the response URL


I have a custom GPT which connects to an API endpoint and retrieves data from a Snowflake table. One of the columns in the data contains a URL to our website.

Even though the URL is returned by the query correctly, when it is displayed by the GPT as a final answer, the URL changes from to

It can then not be opened.

Is this a deliberate feature by OpenAI to prevent redirects or is there something else at play here?

Although this isn’t documented I would imagine it is a feature to prevent people from injecting their own URLs. It’s a good way to prevent ads from appearing again like they did for the plugin store.

Not sure if this is true though.

That is my first guess as well, but just wanted to be sure if I was not missing anything from my end.

It’s worth exploring, honestly. I would be surprised if they flat-out denied people from sharing links. I’m all for it, tbh, but when I think of the people that matter to OpenAI (Zapier) they pretty much need to share links.

It would be cool if the GPT could share links that come from the domain of the owner

1 Like

Here is my guess.

You need to return the URL as a fully resolvable URI. That means you need to include the protocol information, e.g.,

In the absence of this protocol information, standard behaviour is to treat a link as a relative URL within the same domain as the webpage serving the link.

Please test adding the protocol information and report back your results.

1 Like

This results in the same issue.

I believe then it is a deliberate feature by OpenAI to reduce spam.

I am not seeing the same behaviour.

I threw together a dead simple API endpoint to test this,

You can test it here:

Note: I will delete this GPT soon, I just wanted to give you access to a working version where the URL is not mangled.

If you have any questions about the setup of the GPT, let me know.


I just tried out my same GPT with absolutely no changes today and it works now as intended.

Perhaps OpenAI brought out an update?

A post was split to a new topic: Help Creating Snowflake Action