Custom GPT: Action with OAuth-2 showing wrong button for concent

I have a GPT with OAuth 2.0 action. It was working fine till yesterday before the outage. But after the outage I saw that the Action is stuck in permission loop.

If you see the image it seems like GPT wants to get user’s concent on sending data to my site but instead it is showing the OAuth link.

1 Like

So I had to delete my action and then create a new action and then finally it started working.

2 Likes

Does your sign in button disappear after a successful login? Or do you have to type something for that?

Same issue, same fix. The symptom I was seeing is that all actions tried to show me a sign-in button—clicking the sign-in button didn’t even redirect to my authorization link, it just redirected to https://chat.openai.com/gpts/editor/undefined. Notably, checking ‘connected accounts’ showed that my account was already logged out, so there was nothing to reset. I’m guessing it was probably caused by a faulty database migration or similar.

Deleting and re-creating my action solved the problem.

1 Like

Same issue here /gpts/editor/undefined comes as button response after I edit existing actions

3 Likes

+1 same. redirected to /undefined. :frowning:
(solved when deleting and recreating the action)

Yes. This makes debugging and testing really annoying!

Mine got stuck on a loop, and then I hit my max message limit…

I think simply re-entering in your OAuth credentials does the trick without having to delete and re-create, but who knows :person_shrugging: