"Couldn't find manifest." error on "Develop your own plugin"->"Find manifest file"

Hi,

I’m following “github plugins-quickstart” “todo example”.

I’ve set up my domain and I can see the files in the browser when i look at /.well-known/ai-plugin.json

I can see the hits and 200 responses of me browsing the website. I never get a hit from openAi servers. OpenAI UI shows message:
Couldn’t find manifest.
(second image redacted to comply with new user rules)

Why can my browser find /.well-known/ai-plugin.json , but not openAI ?

Please let me know how I can clarify and make it easier to reproduce :slight_smile:

1 Like

Welcome to the developer forum!

This is quite an involved topic, you may be able to see the well-known endpoint from your local browser, but there may be permissions that have not been set or configurations that have not been deployed to your live environment. Quite how this is done in detail varies depending on your environment and the specific configuration for your site.

There are a few good video guides and also documentation guides for doing this on the web, not knowing your exact host provider and setup makes it difficult to recommend anything specifically. I would search the web with a search term like "How to configure my well-known plugin.json for {your host provider here} be that Azure VM, AWS EC2, “some host” VPS, etc. etc.

Hi,

My VM is on GCP. Let me list typical networking details that might matter:

Server with plug-in is HTTP, not https (yet)
Port 80 is used for http
Firewall is open , anybody can read the json file via web browser by making http request ; no need to whitelist openAi servers

That’s all I can think of… is openAi making http or HTTPS request to the “domain.com” that I enter in the dialog box?

I tried search for “ How to configure my openai plug-in .well-known/ai-plugin.json for GCP”, but no relevant results. I feel like we should be able to tell AI plug-in to find the info for me… but feels we are not quite there yet :wink: so thanks so much for your help guys, before we can all offload these pesky networking details to AI :slight_smile:

Have you reached out to GCP on this topic? They may have documentation or at least guides for this.

I’ve been working with Google on GCP for 10 years, and solved plenty of networking issues… even though it’s a personal project where I don’t have support… I know how biweekly meeting with my Google account manger would go: they know I know as much as they do, and they would most likely point to not knowing what openAI side is doing, and why there is never a hit from an openAI server (as opposed to my ISP/browser). Their response would be: if we never see openAI hitting the server, there is nothing we can do to help from our side.

[edited for brevity]

Your screenshot shows the URL is not secure

All traffic with the plugin (e.g., fetching the ai-plugin.json file, the OpenAPI spec, API calls) must use TLS 1.2 or later on port 443 with a valid public certificate. [source]

3 Likes

Thank you!

Let me set up httpS accordingly. Thank you for spotting this networking requirement!

CONFIRMED fixed.

Summary:
What was wrong: my assumption that openAI will search for the manifest using http on port 80.
Actual: openAI will reach to your domain using https. You need to implement https: have your certificate set up and serve the data from port 443.

Thanks to everyone for helping out!