Moving ChatGPT Plugin from localhost to my web server. (and failing, I could use an assist here)

Hello. I have read the forums, searched google, and even discussed this at length with ChatGPT and read all the API docs.

I am extremely confused. When I tested and was happy with my new application in terms of the locaohost version, I set up my own web host, I had a spare domain, (and make sure the SSL cert is working and all that is correct). There are no CORS or firewall issues. I can hit every single file required, and they work from various machines, IP ranges.

When I uninstall the localhost:5003 version and try and put in, I get the following error:


When I load any of the files, including the manifest in the browser, I get my web server access log showing that.

When I try to have openai load it, I get no connections from them to the web server.

For reference, I will show the URLs for the manifest, openapi.yaml so anyone here can see they are visible, proper SSL etc.

I have spent a lot of time on this and nothing seems to work. All the suggestions people have raised in prior posts are not working for me. I have read and re-read all of the API docs and changed and tested more than one thing so far.

If anyone has any ideas or follow up questions to help figure this out, I would appreciate it. I am a long time developer, and this is just a quick test I was doing for the plugins before I do something real I have planned. But if I cannot even get this to transfer properly… I just feel I must either have a fringe case, or I am overlooking something obvious due to tunnel vision.

Here is the relevant routes for the two files:

@app.route(“/.well-known/ai-plugin.json”, methods=[‘GET’])
def plugin_manifest():
with open(“./.well-known/ai-plugin.json”) as f:
text =
return Response(text, mimetype=“application/json”)

@app.route(“/openapi.yaml”, methods=[‘GET’])
def openapi_spec():
with open(“openapi.yaml”) as f:
text =
return Response(text, mimetype=“text/yaml”)

Thank you kindly. Lilith

I noticed in your plugin manifest you have “user_http” set. Haven’t tried that one myself, but I noticed in the plugin docs that “Due to current UI limitations, we are not allowing plugins with “user authentication” into the plugin store. We expect this may change in the future.” - I was under the impression that if you want to persist user state across chats, the only way to get user info is using oauth.

Otherwise could not see anything out of the order

1 Like

That was just me testing various things to try to figure this out. I put it back to:

“auth”: {
“type”: “none”

Same result. Thank you though.

Since you have already deployed your plugin, you must use “Install an unverified plugin”, not the “Develop your own plugin”

1 Like

Thank you but I have heard both things need to take place. Regardless, that does not work either sadly, and the error is even more vague.


Hello, I inspected Chrome while trying to install your plugin, seems there is an issue with SSL certificate :

“Error creating plugin: {"message":"Cannot connect to host ssl:True [SSLCertVerificationError: (1, ‘[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1129)’)]"}”

Possible causes and solutions :


Thank you. I will explore this.

It was a certificate problem. It works now, thanks.