Can I host the service not on the http(80) or https(443) port?

I have built the plugin service on my server on a non-http or https port. My ai-plugin.json file is hosted at

So when I am asked to provide the domain name for ai-plugin, I provide my server as But the system complains that “could not find manifest”. So far all the examples I saw use the standard http or https ports. Is it possible for us to serve the plugin on a customized port? We may not be able to serve our service on the standard ports.

Your help will be greatly appreciated. Thanks a lot!


Hey! Right now, we only support a single port for this as is mentioned here: OpenAI API

Any context on if that doesn’t help in this situation would be useful!


I had issue issue, I just used a python proxy in my config. This runs on port 443 for an app running on port 8080

if __name__ == '__main__':
    logging.basicConfig(level=logging.INFO)'', port=8080)

Thank you both. I have tried a few things:

  1. Move the service to the standard https(443) port.
  2. Turn on CORS from OpenAI.

With all these tweaks, I can get the same code base working on my localhost. I.e., the plugin at https://localhost:8000 works. But if I use the same code, and deploy it to our server, it still does NOT.

Specifically, it always fails with the message: Couldn’t find manifest.
But I can clearly see my ai-plugin.json at
Also I noticed that it seems like OpenAI never issued any web requests to my server. When I use chrome to access my server, I can see “200 OK” messages in my sever log. But I never saw these messages after I typed in my URL at chatgpt site.

What could be preventing openai server to even access my server? @logankilpatrick Your help will be greatly appreciated!

1 Like

One quick update. I know we are not using an officially certifies SSL cert. We are going to upgrade it asap to see if it helps.

1 Like