Copy and Paste Issue in ChatGPT Desktop App on macOS

I think the copy issue has been fixed, it won’t being pasted as an image.
However, after generating a table, I can only copy the text inside a cell but not the whole table. Anyone having similar issue?

Nope. I’m still getting this issue as of 1st June.

1 Like

no, I don’t think so… still not working as expected

I have found a solution. PlainText-CopyPaste Cleaner App, which clears out all the text formatting whenever you copy/paste.

It’s pretty useful in other places where you need to copy-paste a plain text. The good thing is that it can be turned on/off depending on your copy/paste needs and is quite inexpensive. I usually keep it on, unless I occasionally want to move formatting with my texts.

1 Like

I have the same issue here and each time I need to paste the content into the notes app of the mac and then copy it again and paste it into the app!

1 Like

Same issue and as suggested by other users this seems limited to MS Office apps. I have experienced this behaviour both from MS Word and MS Outlook. My current work around is to paste it into text edit, copy the text, then paste it into the ChatGPT app.

1 Like

I have the same issue on my Mac on the web version

1 Like

same problem using de MacOS App Version 1.1 (856)
not happy after buying AI Plus…

1 Like

I am having the same problem with pasting from Word into the Mac desktop app.

1 Like

Same problem. If you want to stay in the Mac world you can CMD-C from Microsoft, CMD-V into notes, highlight and CMD-C from notes, and CMD-V into ChatGPT. It sucks, but it works without buying anything additional. I am sure there is a recipe we could put together to solve for this. The web version does not have this same issue. For me, the web version does both. It puts it there as an image and as text, but ChatGPT is still able to give me a response.

1 Like

OpenAI should build it into the app though so 3rd party apps aren’t necessary for copy and paste functions

yup that works, but OpenAI should make it easier than this

same here, I found it’s when you use any Microsoft application to copy and paste into ChatGPT Desktop App. I have worked around this doing a copy and paste from “Word/Outlook” in to “Notes” and than into ChatGPT. Hopefully it can get fixed.

I have a ver easy solution without the need to use additional software.

Open TextEdit and paste the text, then, copy that text and paste it into the ChatGPT app.

That’s it!

This is not working for me and I so wish it would. Copied/pasted to TextEdit and then again and over to ChatGPT several times and no joy. Did not have this issue with Word and ChatGPT until this past month. Wonder what has changed.

Was attempting lots of copy/pasting from Word to ChatGPT Desktop and was getting frustrated doing the TextEdit thing but I found a real workaround! There’s an old menu bar app in the App Store called Get Plain Text, it’s free, and there’s a setting to automatically clear formatting whenever you copy text to the clipboard. So far it seems I can copy/paste from Word to the desktop app seamlessly with 0 issues at all! It’s annoying that this is a necessary step BUT it also clears formatting when I copy/paste from ChatGPT back into Word-- yes, option-command-V works, but it’s just a QOL improvement. Hope this helps y’all!