ChatGPT's inability to read Excel files

In case this is interesting…

A few days ago, I set up a personal (private) GPT to demo something I am interested in within my professional field which is the risk, compliance and control space. Yesterday, for the first time, I tried to use my GPT to analyze spreadsheets and got nowhere, which is how I found this thread.

This morning I tried to do the same thing using Chat GPT 4 (the Plus plan version) directly and everything worked perfectly. (The tasks involved looking at multiple spreadsheets that I uploaded and following instructions to find patterns I was after and display items from rows that met my inquiry criteria, e.g., look at a vector for pairs of data that occur in a reference table from a different spreadsheet, and display elements from the rows containing one of the pairs of interest.)

I was patterning what I did after a You Tube tutorial (search for Corbin AI) but there was nothing tricky about it. When I paste the same prompts that had worked directly in GPT 4 back into my private GPT, it’s still failing.

Has Open AI fixed something or do I just have a lucky use case, I wonder?

3 Likes

Exactly the file that it analysed previously , now it says it cannot open. I wish I could merge multiple chat. The analysis a few days ago was exactly the way I wanted. And today it wont even open the excel. There must be a workaround here, I hope. I know €20 isnt a lot of money that they are charging, but QOS is important for such a valuable company.

1 Like

Hola,
Me ha ocurrido lo mismo con GPT4.
La semana pasada introduje una hoja Excel en su configuración que debía utilizar para completar las celdas según ciertas instrucciones y cuando realicé las pruebas funcionaba perfectamente, hasta el viernes día 19/03/2024 que dejo de funcionar y al preguntar - ¿Por qué motivo no tienes acceso a editar archivos Excel en este momento? La semana pasada sí tenías acceso y sí cumplías con mis instrucciones.
Su respuesta ha sido: Lo siento por la confusión. Actualmente, no tengo la funcionalidad para editar o manejar archivos directamente, incluyendo Excel. Esto podría deberse a una restricción temporal o un cambio en las herramientas disponibles para mí.

1 Like

I’m having the same issue. Last year I was able to analyze Excel spreadsheets without a problem. Now I continually get errors. It says that it’s unable to access the file, even when I re-upload it. When it could access the data, it was giving me incorrect results.

1 Like

Same issue here - except for me it worked last week and now the same files generate an unspecified error:

It seems that I’m still unable to read the .xls file properly. This issue might be due to how the file is formatted, or it might require specifying additional parameters like the sheet name if it contains multiple sheets.

But the files are the same and i re-saved them in various different formats (csv, xls…)

I have been experiencing this issue as well. At first, I thought it was the external links, but I got rid of those and even tried with just a data CSV.
It almost seems like they allow you to do it a few times but the next day it always has issues.

I also have issues with excel. Been messing with it all day, turns out GPT4 simply cannot access the names of the sheet and this just spits out the error.

any idea of good chatgpt4 alternatives? sick and tired of all the recent issues despite paying for it.

I documented the same error on another post.

It’s VERY frustrating to be paying for this. It works every time on any NEW conversation, but then I have to give all of the instructions on how to interpret and process the data again and again. This doesn’t work.

They MUST fix this ASAP.

Even the agent in the conversation agrees this is not a normal situation!!

1 Like

Someone here told to export documents as PDF! I did it and had great result! I dont know why chatgpt is facing these issues reading excel files but at least now I know exporting as PDF works

I’m surprised to have searched this issue and found OpenAI hasn’t addressed this.

However, the workaround of converting the spreadsheet to PDF from @jamie.danjoint worked for me. Thanks!

I hope a solution is provided soon.

This is interesting. I would expect to chat with my document to get values vs giving exact string matches. I have experience the inability to query excel a lot of the time.

I too am experiencing the same issues as everyone else. After trying to upload excel files for 2.5 days, all of a sudden it started read my excel files. I uploaded everything as fast as possible, tried to add another factor to be included in the analysis, then forgot the original data. Cannot get it to work.

I now tried with PDF files, they upload but experiencing almost the same issue once it receives the data. Sometime it works and other times it asks for the data again, which can be hit or miss. Not a usable tool. SAD!

Once again, after receiving 6 years worth of data, providing me summaries, I get this response:

ChatGPT
It appears there was an error with accessing the data. Let’s try extracting and verifying the data again from the PDF files you provided.

I will extract the financial data and create the comparison charts based on that data.

Let’s begin with extracting the information from the provided PDF files. ​​

It seems there is an issue with accessing the PDF files directly. Instead of attempting to process the files programmatically, let’s focus on what we can do manually based on your provided data.

Please provide the key financial figures (Income, Expenses, Net Income) for each fiscal year (FY2019 to FY2024) manually so I can create accurate comparison charts for you. Once I have these figures, I can proceed with the chart creation.

Same here, this is insanity.

To be fair we are using GPT 4.0 as if it is GPT 5.

I spent hours teaching Clarella (my name for ChatGPT) how to do something with excel exports. I finally got it and then boom…she can no longer read the exel files anymore and cannot generate any for me anymore either.

The PDF option doesn’t work for my purpose because I am having Clarella create excel files using the ones I gave her. I am paying for this service and now, on a time crunch, I cannot utilize the thing I spent my whole day working on to save me time when I could have just done the work myself. I now have to work late to accomplish what I need. Ridiculous!!

This issue is very persistent, with no hope of improvement ATM or even acknowledgement from OpenAI, to my knowledge. First sings of this issue were reported in April last year. :confused: Good luck everyone with issue!

On plus version it happens when there is a longer delay in response from the user in one conversation (15-50min). Then the analysis tool loses the ability to read and create files, with exception of (only reading) PDF files. Custom GPTs are usually closer to the 15 minute mark, plain GPT 4/o closer to an hour.

Here is an issue summary from the GPT itself:

Issue Name: AceInternalException during (Excel) File Operations

Description:

When attempting to read, modify, or write Excel files using pandas and openpyxl in the sandbox environment, the process fails with an AceInternalException. This issue prevents the successful execution of file-related operations, which are critical for tasks involving iterative analysis.

Hopefully there is an improvement here.

I am an accountant who is interested in AI charged by my company to explore how ChatGPT can help us with manual tasks.

I have asked ChatGPT to analyse an anonymised bank statement and reconcile it to the accounting ledger entries. The reply to my prompt seems to indicate ChatGPT understands what I want it to do but gets stuck manipulating the excel spreadsheets.

It’s a pretty simple sheet of 2 datasets containing dates and transaction amounts.

The solution it gives me is to provide a python script to run and do it locally, I have some experience creating and running scripts in the past but this method may be a little beyond most of the people I work with.

1 Like

I am getting this error message from chatgdp 4o “It appears that I am currently unable to install the necessary package to read .xls files. However, if you can save the file as an .xlsx file format (which uses a different library for reading), I will be able to read and analyze it. Could you please convert the file and upload it again in the .xlsx format?”

This is very frustrating and disturbing especially for a paying user !

The best workaround I have found is to use csv files instead (save your excel as csv, open it with a text editor, copy/paste it in the chat text area). This is a limited workaround though.

and btw, this issue happens with PDF files too (missed pages).

It’s fascinating that the company building the future of AI is unable to address such a big issue after months of users reporting it. The most worrying part is that some users might not even be aware of the issue and get to incorrect conclusions assuming chatGPT read their files correctly.

If it’s a file size issue, show an error message beforehand, if it’s a processing error, showing an error message to explain.

A simple repro scenario: create an excel spreadsheet with 35 elements/rows and 3 columns, fill it with random data, upload it, ask chatGpt to list the contents in a table, it fails to display all rows (total rows displayed: 26).