ChatGPT Mac desktop app "Sign in failed"

I received the invitation to download the ChatGPT Mac app, and installed it on a compatible machine (M1 Air).

Every time I try to sign in, I get the error below. I have tried restarting the device, uninstalling/reinstalling the app, clearing cookies/cache, enabling/disabling iCloud Private Relay, changing default browsers, etc. Internet connection is stable.

I am able to sign in to the ChatGPT app on iPhone with the same account without issue.

Has anyone who ran into this issue solved it?

Here’s the error message in full:

Something went wrong. Please make sure your device’s date and time are set properly. Check that your internet connection is stable, then restart the app and try again. (code:48ADA4A5-16D9-45B1-B2B9-D5929D8D02AC,API.DeviceCheckError,2)

3 Likes

I managed to login but everytime I try send a prompt I get this –

Same sign in error. How did you manager to sign in?

i have same error, do you find any solution ?

Same issue here. I’ve tried everything but no luck. I’m able to login easily on the web and also on my ios app, but not the mac desktop app. If anyone finds a solution, please share it. Thanks!

same issue, please roll out fix.

I tried everything, every time zone my country has, every combination of VPN, private relay, deleting cache, reinstalling the app, the trick some ppl wrote when they didnt had access yet — cmd+Q directly after login, login in with different login methods, using completely different internet connections, different macOS versions.

If you make a small step by step release, at least use the luxury to listen then to feedbacks and immediately fix it — this is just embarrassing.

1 Like

facing the same issue here man

I solved this problem by disabling private relay for the login page. When chatGPT app opens safari page for login, go to safari menu ‘View’ then ‘Reload Page and Show IP Address’.

This didn’t work for me, but perhaps it will for others.

didn’t work in the view there is no show ip address but i changed it from settings and i don’t have icloud+ so private relay is not turn on i guess

Can we please get a statement of a dev, this starts to be a bit embarrassing.

Or at least feed chatgpt a live feed of the code for your interfaces, so it can give technical support for itself with every release.

5 Likes

So many weeks since this issue was reported the first time and still - no public response from a developer.

This is a level of b2c communication normally only seen by blizzard and support like adobe.

2 Likes