Can't upgrade to chatgpt plus

I can’t upgrade to chat gpt plus, it just gives me this dialog and I can’t click anything. I definitely don’t already have the plus plan, see screenshots below. I have tried logging out and logging back in and doing some hard refreshes in my browser, which is chrome. I have tried in an incognito mode. I have also tried in microsoft edge.

3 Likes

Definitely a bug in the site. When I hover over the that grey button, the cursor turns into a small red circle with a dash

This is proof that I don’t already have the plus plan. I used to a few months ago, so I wanted to renew my subscription.

Screenshot 2023-10-05 202623

I just tried on firefox and the same thing is happening.

Same issue - also using Firefox. Had the option to upgrade yesterday, but I was in a rush so thought I’d do it this morning. Has anyone else had this issue and found any workarounds?

1 Like

me toooooooo.
Easy fix: Upgrade from mobile app.

1 Like

Same issure here, cannot upgrade it and i require it urgently, same grey button…

1 Like

Upgrading from mobile app worked for me too. Via apple subscription. Thanks for the tip!

1 Like

Been using GPT 4 for few months but today i cannot renew my subscribtion :roll_eyes:

1 Like

Payment button is grey. Please fix it asap

Hey if it’s urgent, download the mobile app and subscribe there. It worked for me. After that, I logged out and back in on my desktop and now I have Plus access there again as well.

1 Like

That worked for me! Got new subscribtion! Much appreciate Nzzizilia!

1 Like

I also had this issue on chrome (on latest update), even after logging out, clearing my cache, cookies and opening an incognito window. I had to use the workaround of signing up for Plus through the iphone app via apple pay.

Looks like a recent bug with the browser version.

1 Like

Ya it worked to upgrade in my android app, then hard refresh in the browser. Still a pretty bad bug thats in production!

1 Like

Can’t even upgrade from the phone anymore - IOS

Neither can I.
I’m using chrome. Please check my dashboard.

Why can’t I extend Plus? I’m using google chrome.

Update: The problem has been fixed. I went into the browser in incognito mode, logged in, and was redirected to the payment page. After payment, I connected Plus and got access to the new options.

I wanted to upgrade to Plus. I am not able to click on the verify me as a Human button, it is only Text. Can’t do it over the iOS App, cause App Store is linked to another CreditCard. Tried it on Mac, with Chrome, Safari and Firefox.

2 Likes

+++, button not working at any devices

1 Like

I’m also experiencing the same issue. I’ve tried both, Chrome and Firefox, and the same thing happens in both browsers.

1 Like