Can't update GPTs that have "close to" 8k chars in Instructions _ PLEASE HALP SMART PPL

Here is a video of my issue: ChatGPT

Note: If your instructions contain instructions they deem a problem, you can’t save.

Try copy and pasting and saving in chunks to see if there is a section they deem to be a problem.

Alternatively, ask the GPT itself why it can’t save. This has never helped me, but can’t hurt to try.

1 Like

def one of those creative ideas where i could see it being like 'here’s why, guy…" lol

Will check this out. What’s weird is I created a new GPT entirely, and pasted in the full set of instructions with no issue and it works like a charm…but unfortunately that is a whole new URL I’ll have to roll out to my existing users…ugh.

and then when i try to edit the new model, same circle of errors occurs - so strange.

I wish I had better news, same thing was happening to me with far fewer instructions and the only thing that worked was to create a new GPT and retrain. The problem is you need to be very careful about what you re-add. If it was under a “content” issue there is a huge likelihood it will happen again.

I ended up copy/paste all my training into my own files, scraping out identifying content and reloading it into GPT.

Good luck!:+1: let us know if you find another way

1 Like

I had exactly the same problem with a GPT with only about 2500 characters in the Instructions, plus one Action with an API call. It was Public.

I eventually made a new GPT, copying and pasting over the Instructions and Schema, etc. It worked fine to start, but then after one or two further small changes to Instructions it once again gave me “Error Saving Draft”.

Frustrating. If anyone finds the solution, please let me know too. Maybe it’s an OPENAI bug?

1 Like

And this morning it seems to be letting me edit the new GPT…but still not the originally one. Just strange but gives me hope that it is at least possible

Have had the same thing across multiple GPTs. It will let me upload some files, but then breaks all draft saving. Sometimes draft saving will break while editing instructions only and sometimes when using the builder. Happens with small prompts and small files. Have also had trouble getting a logo image to stick if I upload it to the builder. Seems to have broken the whole GPT logo image functionality.