Cannot sign in with google oauth in new browser

I’m trying to sign in to this forum using a Microsoft Edge browser, through my OAuth2 authorization, and it fails.
It takes me to the Google select-your-account page, and then I get an error in a pink box saying:

“Could not retrieve your user details. Do you have an active account?”

Checking my account security details in a signed-in browser (Chrome on another machine) it claims that I have an account, and it’s using OAuth2 from Google.

I’ve tried clearing cookies, and still get the same error.
I can sign in with the same Google account at It’s only this forum that somehow fails.

1 Like

Interesting. It’s only the Edge browser?

Honestly, I didn’t think to check, because I just switched to the already-logged-in Chrome on my macbook…
Might also be something like ublock configuration being different.

I opened Chrome and cleared cookies, and then tried to log in with google oauth2, and I got the same error:

have you logged back in to something like gmail with that browser after clearing your cache?

I was getting a similar issue, clearing the cache seemed to work for me. I flagged to @sam.saffron


Same issue. Clearing cache and cookies didn’t help. Using Firefox & Google Auth Provider :man_shrugging:

I can log in to other websites, including the OpenAI API management/platform website, and
Although, now that I think about it, I’ve cleared cookies, not all possible state. Maybe I’ll try that next.

1 Like

Cleared all site data (indexedb, cache, cookies, …) and still get this problem.

There is some information on this topic, but does it really exist in different browsers and clearing cookies doesn’t help at all.

I have seen this in both Chrome and Edge, and someone else reports it in Firefox.
Clearing cookies, and clearing all browsing data, does not help.
The Google OAuth side works fine, but once it’s back on the forums, it says it can’t match an existing account.

1 Like


I cannot resolve this issue, but I’m actively seeking help for it.



This appears to be fixed.


The other day when I posted this

shortly after, I too was not able to login or create a new account.

Obviously I am now back on this forum so this appears to be resolved.

For those that posted in this topic, please let us know if your login is now working.


I’m still not able to log in via Google (as communicated on meta) on a new browser.

1 Like

No, I still cannot sign in on the forums in Edge using Google OAuth.
Still get the “can’t match to a user account” error.

Trying to log in as that particular Google Oauth account.
The Google side works fine (I’ve even logged out and logged in through the flow again) but the match-up on the OpenAI side fails.
And note that this works for the side (different account, obviously) but not for the side.


For this post using Google Chrome which is my primary browser. I did not need to clear the cookies for this to work. My Google account was already active for this browser. It just seemed to work when went to access the site with nothing more than normal.

Just now in trying to use Microsoft Edge which was not running, it did not work. Also tired clearing the cookies and logging in and that did not work.

Wondering if they have to remove each user from a list by hand for this one? No I have not heard anything from anyone at Discourse or OpenAI regarding this but do know that Discourse is aware of the problem and that it may not be with their code or infrastructure.


From Discourse

We have a repro here and I put a #pri-high::tag on this, an engineer will be looking at this some time in the next 4 business days.

Sorry I can’t provide a link as it is a DM.


I think this is sorted now, is it working properly for all the people that had issues?

1 Like


thanks to whoever fixed it :slight_smile:

1 Like

Completed a successful login with Google OAuth using

  • Google Chrome
  • Microsoft Edge
  • Firefox
  • Apple Safari on iPhone