Can not change a GPT icon?

I created a GPT and want to change icon.

There are two options: Upload Photo and Use DALL-E 3.

“Upload Photo” doesn’t work for me (maybe a bug) and “DALL-E 3” would change instructions.

Same problem here. I’ve tried uploading a PNG and JPG with a 1:1 ratio.

1 Like

I’ve also tried webp with no success (ironically from dall-e 3 as I don’t like the automatically generated options!)

1 Like

EDIT: I tried uploading an image via the “Create” chat. While it looked like this was working, it didn’t persist with the GPT… :cry:

Within the Editor

When interacting with the GPT

I tried your suggestion, and while it uploaded and displayed the image while in the configuration mode, it didn’t seem to save (even though I saved the GPT). However, it would seem the standard way for uploading an image now works properly for me.

Doesn’t work for my account too. No errors it just doesn’t work. Is it related to the overload?

I didn’t work on my account, then it did, then it didn’t.
Yes, I think it’s an overload issue.

1 Like

The problem persists. I created a new GPT and was successful at uploading a thumbnail, but it did not save it. When I select to upload an image again, the upload doesn’t occur after selecting the image file. I am shown a broken image GPT text, and if I select DALLE then I cannot replace that image with my own character image.

I confirmed a workaround from another thread:

Yes, the create + upload works:


SELECT THE ‘CREATE’ TAB

DROP IN AN IMAGE TO THE CHAT

ChatGPT: It seems you’ve uploaded an image. How would you like to proceed with this? If you’re looking to update the profile picture of the GPT, I can assist you with that.

User: update my GPT image please

ChatGPT

The profile picture of the GPT has been updated successfully. If there’s anything else you’d like to modify or any assistance you need with the GPT, feel free to let me know!