Can't update Logo for custom GPT

Either through direct upload or via the builder. Disabled all content blockers, but the UI just times out. No error thrown.

1 Like

I also meet the same problem.


Any official update on this? Still can’t change/add the logo, even when starting over.

1 Like

I am able to get around this by asking create tab to upload this image as AI's avatar

Yes, the create + upload works:



ChatGPT: It seems you’ve uploaded an image. How would you like to proceed with this? If you’re looking to update the profile picture of the GPT, I can assist you with that.

User: update my GPT image please


The profile picture of the GPT has been updated successfully. If there’s anything else you’d like to modify or any assistance you need with the GPT, feel free to let me know!


I did that but the image disappears after a certain amount of time (I think a couple hours?) if I do it that way. Now my logo is just the default image that appears when an image url is invalid.


I have the same Problem. it had been updated with the new picture, but when i go to the user interface i doesnt appear.

1 Like

Issue still is there. I tried jpg en png in different file sizes. I can upload and set the logo succesfully, but every time the logo shows a 404-error after a couple of hours.

1 Like

I had this problem for a while now. I then choose another browser (chrome instead of safari) and changed the image from png to jpg. Then I used the upload function of the logo, which was only working in chrome for me.

Since that, my GPT has a logo.

1 Like

Are you on Desktop or mobile? e.g. On my iPhone, safari browser, never worked

Same issue here, the logo is broken… tried so many workarounds but the problem seems to keep happening even on a new plus account… any ideas how to overcome this issue?
Screenshot 2024-01-10 at 15.26.12

1 Like

Doesn’t seem to work on Safari, have to use Chrome to change the image once it’s set.

Using Chrome :frowning: Still having issue with uploading a logo…