Unable to collab on a custom gpt in "Team"

So I saw that someone in “openai-chatter” channel on discord was having an issue configuring a GPT with a Team member in the new “Team” environment & I figured I would reach out to try & help. Turns out their may be a bug in the platform with regard to configuring a GPT in a collaborative environment. Tried changing perms etc but nothing seemed to work, I even tried entering into config mode & copying the link to a team member as a work around but that didn’t work either. Please Advise!

And of course,
Thank you in advance!

3 Likes

Hello, I ran a test on this this morning. As far as I can tell you can not edit a GPT that someone else in your Team Workspace is the Builder of. The other person can of course share the GPT with you to use. But I do not believe there is the ability to edit a teammates gpt.

4 Likes

Are you able to collaborate on a “regular chat session” in a Team workspace?
When I share a chat with a colleague, he is unable to continue the interaction from the point I stopped…
Would appreciate advice of how to do even a basic collaboration!

1 Like

I have the exact same problem. I would like to be able to cooperate with a team member to co-create, co-upload docs, aso. Have anyone found a solution yet? Maybe OpenAI will address this issue? Basically i want a CO-HOST by invite on my custom GPT’s :slight_smile:
Hope someone can help.
Have a great Weekend…

2 Likes

Nope, I am in the same situation as you. I would imagine they will end up adding this as a function later on but as of now it doesn’t have the ability.

2 Likes

In the ChatGPT Team plan, GPTs are initially managed by their individual creators. Collaborative editing is facilitated by the Owner of the Team workspace, who can reassign GPT ownership to different members. To do this, select “Manage Workspace” followed by “GPTs” from the Admin panel.

The designated builder can then edit and publish updates. For further collaboration, the Owner can repeatedly reassign the GPT to different members as needed for ongoing edits and improvements.

3 Likes

There is no such an option.

2 Likes

Are you perhaps attempting to share a GPT that was originally created in the personal workspace?

If not, and you are the Owner, this may be a bug that you are experiencing.



3

Wow, there must be diligent little elves at work. Suddenly the GPTs option is there.

:smiling_face_with_three_hearts:

3 Likes

Hang out here enough and you learn that that is not the exception but more of the norm with rollouts.

2 Likes

We are still struggling to get the sharing of Custom GPTs to work within our Workspace for our ChatGPT for Teams. Everything seems go smooth when creating a new Custom GPT and when we go to GPTs > Change who has access and sets it to our Workspace, non of our members can see it.

Also, when creating a shared link for both Workspace and Public, it gives the error GPT inaccessible or not found. :roll_eyes:

Screenshot 2024-06-11 091805

Okay, apparently the problem was as simple as pressing the “Create” button to “Create” your GPT, even though it looked like it already was, since you could already use it and share it too. This was not entirely logical to understand. Perhaps the button should be renamed “Publish” or something more ideal.