Unable to access Advanced Data Analysis

“Code Interpreter” / Advanced Data Analysis STILL not available to me as a Plus subscriber. Confirmed there is no toggle to enable it within the Advanced Data Analysis section. @support why?

1 Like

Hi,

Can you please include a screen shot of your settings screen, and the main screen when you first log in.

I do not have access to the Advanced Data Analysis option either.
I did, but it is now gone. I am a longtime paying Plus user.
(I can only post one pic per post as a new user)

I’m having the same exact issue. Is there an update as to when it will be available to all Plus users? I can’t find any information to troubleshoot this issue on my own.

Same problem here. Would love to get some updates about fixing the issue.

Every subscriber to ChatGPT Plus should have access to Advanced Data Analysis/Code Interpreter.
That’s why there is no toggle anymore because it is automatically active.
I propose you try to upload a file and have the AI do whatever you want. The only thing that could interfere is that the model replies with “Sorry, I cannot do that”. In this case you need to push it a little bit.

This is likely a misunderstanding. Will be interesting to know if this is not the case.

1 Like

Also, as a backup, if it still doesn’t work, or doesn’t want to work the way you intended, there is an “Advanced Data Analysis” Custom GPT in the “Explore” tab that you can use. As vb said, I think it’s just automatically integrated at this point, but if not, the custom GPT should resemble the earlier methods of using that specific tool and only that tool.

1 Like

I have the same issue. Did you get a fix from OpenAI team?

Confirmed: having exaxctly the same issue:
Only plugins available, but no ADA.
Giving access to advertized features should be a must-have for a paid service, shouldn’t it ?
(see: https://help.openai.com/en/articles/8302319-why-can-t-i-see-code-interpreter)

ChatGPT Plus no longer requires the manual selection of “advanced data analysis” for code interpretation tasks, only the selection of GPT-4.

image

You can invoke it casually by a task that requires computation, or directly by asking for “python sandbox execution”, such as “use your python tool ability to calculate the sum of the first 100 decimal point digits of PI after radix”.

1 Like

I have the same issue, just signed up for ChatGPT Plus Subscription, but dont see ADA under Beta

Thanks for the comment. Do you still have the “Advanced Data Analysis” option in your subscription? Or it has been removed. Thanks.

When you pick GPT-4 as the model, with a screen shot seen just three posts above, you will note that it says With DALL-E, browsing and analysis.

Their lack of oxford comma may make it less clear, along with not spelling it out for you.

If you want only advanced data analysis (python code interpreter), without the others enabled, you can “explore” and pick the data analysis GPT.

I’m not sure whether the “Data Analysis”, which should be one of the GPTs in the Explore, is the same as the “Advanced Data Analysis” in Beta features. From this link: https://help.openai.com/en/articles/8437071-advanced-data-analysis-chatgpt-enterprise-version, I knew that Code Interpreter was renamed as Advanced Data Analysis. I don’t know whether the “Advanced Data Analysis” option has been removed from Beta features in the Settings on all ChatGPT Plus subscriptions or not, which is the thing I’m eager to know.

In default GPT-4 by selection of just the model selector (where you can also choose GPT-3.5), all tools are enabled. That includes advanced data analysis which can write python code and run it in a sandbox to perform calculations or process attached files.

With all the tools enabled, browse, dalle, and code interpreter (renamed to advanced data analysis, or just “analysis”), the AI is pre-loaded with text telling it how all those operate. That can distract it from its mission of just being a code-based problem-solver.

The GPT builder allows the designer to turn on and off each of those tools when they make a GPT agent. OpenAI made a few GPTs themselves under “Explore”, where they turned off all the other tools except the single tool you’d want.

There is no more "beta features’ or toggle switch for code interpreter.

Thanks for the info. It’s good to know all the details and I think it will be very helpful and reducing confusions if there is a further update with the information above and some screenshots on this post: https://help.openai.com/en/articles/8302319-why-can-t-i-see-code-interpreter. If there will be a further update, I think I will stop searching for the “Advanced Data Analysis” option in the Beta features in the Settings.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.