Ugh, nonstop 500 "error processing" for 50%+ of calls (solved)

Just constant randomness for the past hour, now feels more like two out of three attempts in total, and a bunch in a row.

My project is allowing me to switch models and get the same error between both gpt-3.5 and gpt-4 and both of their prior checkpoints.

500 {‘error’: {‘message’: 'The server had an error processing your request. Sorry about that! You can retry your request, or contact us through our help center at if you keep seeing this error. (Please include the request ID…

(Fun fact, this is an error emitted from internal endpoint to model connections, not any network problem, and can be seen in the API swagger specification)

Latest openai python and its new “robust” connections.
Anyone else up to verify and commiserate?

works fine for me

Thanks, I have an even more extensive usage log for my period of time. :stuck_out_tongue:

I figured out my errors are being triggered from the endpoint not taking certain types of character sequences as input or output, but oddly only sometimes. Running at the edge of tokenization experimentation…

1 Like

Can you please share your findings? Struggling with the same thing :slight_smile:

Edited: Replying to an earlier answer instead of creating a new thread.

Basically the API has a parser of the language output by the AI. Anything that it doesn’t like, for example a function-start token followed by not a complete function, gets you a 500 error instead of telling you what the AI produced so you can fix it.