Constant server_error errors on GPT-4-0613 calls in the past three days

I’ve been using the GPT3 and GPT4 for a product for my company, and the APIs responded generally well those past couple of months, including the new gpt-4-0613 last week. However since Monday when doing queries on gpt-4-0613 I’m getting regular errors like this one:

{“error”:{“message”:“The server had an error while processing your request. Sorry about that!”,“type”:“server_error”,“param”:null,“code”:null}}

It seems to happen more often with queries with more token (around 4k), otherwise it’s fairly random, a query that worked fine one time will fail the next.

Has anybody faced the same? Thanks!

Does sound like a server issue, these usually get resolved fairly quickly, and you can also encounter them when the system is at peak load.

A little graceful error handling and an exponential back off retry system would help, but there is not much to be done if there is an issue at the time, is it better now?

Don’t use the -v-number variants

OpenAi is just giving it to you so you can compare a given model to another

But they don’t allocate ressources

Have the same PB at the beginning

Always use the generic 3.5 or 4

May change but available

Right now it seems to be running slowly but without error. Hard to say though since it’s always a bit random.

I’m implementing retry systems for cases that allow for it (background tasks), but that specific use case is directly tie to user input so a retry system doesn’t make much sense (at least as long as individual calls already take over a minute).

Thanks, I switched back to the regular gpt-4 models for all my previous features that worked fine with it. I have a new feature that requires functions though, so for that one I’ll just wait until the new model is rolled out as gpt-4 before deploying it more widely.

(On a side note, functions are awesome. Best improvement to GPT since the release of GPT-4, amazing how easy it is to work with them!)

Check this site for the status of the OpenAI services:

I did, but it states that everything is fine even though I was getting regular errors. Anyway, this morning it’s working well, hopefully it was just a temporary saturation.