Gpt-4 is producing server error out of nowhere recently

Context: Been running gpt-4 chat completion for the longest time with no issues. Today, it started to produce the following error.
“The server had an error processing your request. Sorry about that! You can retry your request, or contact us through our help center at help.openai.com if you keep seeing this error.”

Solution: I switched my model to gpt-4-0125-preview and now it’s fine. I have no idea why.

Hi @elhjouji.zakaria - Temporary issues are quite normal to be honest. Glad you found a solution.

If you don’t already, it’s quite useful to follow the official OpenAI Status page:

I’ve been getting the same error on chatgpt-4 playground for the past 5 hours. Anyone experiencing the same thing?

1 Like

I have been getting this error consistently since last night on the streaming endpoint with gpt-4:

openai.APIError: An error occurred during streaming

I have created a minimal example based on the docs to test and get the same.
Client version 1.12.0

from openai import OpenAI

client = OpenAI()

stream = client.chat.completions.create(
    model="gpt-4",
    messages=[{"role": "user", "content": "Say this is a test"}],
    stream=True,
)

for chunk in stream:
    print(chunk.choices[0].delta.content or "", end="")

I do not see anything on the status page but it seems like something broke server side.

+1 for me. The old gpt-4 models stopped working over night, only the turbo variants are working (streaming via API).

network errors, duplicate answers, non-existant words…

open ai gpt team is maybe busy and reallocated to sora.
:man_shrugging:

Is this a joke? It’s been 18 hours to an API being down for production workflows and no response, not even an update on their statuspage.

I’m so glad we added Anthropic as a fallback. May have to switch the order of LLMs.

1 Like

Hey folks, I am not able to reproduce this right now, I am seeing the following for the example above:

ChoiceDelta(content='', function_call=None, role='assistant', tool_calls=None)
ChoiceDelta(content='Hello', function_call=None, role=None, tool_calls=None)
ChoiceDelta(content='!', function_call=None, role=None, tool_calls=None)
ChoiceDelta(content=' How', function_call=None, role=None, tool_calls=None)
ChoiceDelta(content=' can', function_call=None, role=None, tool_calls=None)
ChoiceDelta(content=' I', function_call=None, role=None, tool_calls=None)
ChoiceDelta(content=' assist', function_call=None, role=None, tool_calls=None)
ChoiceDelta(content=' you', function_call=None, role=None, tool_calls=None)
ChoiceDelta(content=' today', function_call=None, role=None, tool_calls=None)
ChoiceDelta(content='?', function_call=None, role=None, tool_calls=None)
ChoiceDelta(content=None, function_call=None, role=None, tool_calls=None)

Can anyone provide a request ID for us to take another look at this?

Possibly related or narrowing things down, a similar or possibly the same issue was affecting,

  • some accounts consistently
  • gpt-4 (gpt-4-0613)
  • when streaming responses

We just rolled out a potential fix, can folks give this a try and let me know if they are still seeing this error?

Okay this should now be resolved, thank you all for flagging an being patient while we worked to address this!

1 Like

not resolved at all, I keep receiving the same error message
“Something went wrong. If this issue persists please contact us through our help center at help.openai.com.”

Can you share a code snippet for what you are doing?

If you are in ChatGPT - the web page chatbot - it is not the same issue. The concerns in this topic were about a particular developer API model that is not used by ChatGPT.

3 Likes