Team Workspace Upgrade Not Showing After Accepting Invite

I got an invitation to a Team Workspace. I accepted the invitation, but the paid version/Team Workspace isn’t showing on my account. I’m still on the free version.

I have a similar problem, hoping someone else sees this. I have a friend who created an organization, and sent me an invite. The acceptance link went to platform.openai dot com, but there is no indication there that I belong to any orgs. When I click on my profile pic in the top right, there is only a list item for my default “Personal” org. In my settings, I only see the “Personal” org, but not the other one. I’ve tried logging out and logging back in again, and I’ve made sure I’m logging in with the right credentials.

We followed similar steps on chatgpt dot com, and after accepting the invite, I can indeed see that I am a member of the org that we created there, and I can see its settings, etc. The problem is with platform.openai dot com, which means that I can’t create a Project, which means no API keys, which means we won’t be paying OpenAI any money to use it.

What does your friend see when navigating to,

If you,

  1. Navigate to
  2. Open Chrome DevTools (or similar feature for whatever browser you use)
  3. Open the Network tab
  4. Filter to Fetch/XHR requests
  5. Refresh the page you opened in Step 1

You should see several backend API calls, including one called login.

If you click on this call, then open the Response tab, you’ll see a bunch of information associated with your account. DO NOT POST IT HERE! Much of this will be sensitive information.

But, if you scroll down a bit, in the JSON response you’ll see a key named orgs.

If the account you are currently signed into has been properly added to an organization, you’ll see it listed here.

You’ll also see some stuff in there which will tell you about your role in the organization. Depending on which role you were assigned, your view of the org may or may not change in your dashboard.

Hi elmstedt,

Thanks for the prompt reply. I did as you suggested, and I do see the backend login XHR request, and in the JSON payload under orgs: {... I also see the org I was invited to, along with the default Personal org.

I don’t doubt that I’ve been properly added to the org. The problem is that the platform.openai dot com website is not reflecting that I have been. I need to be able to use the website to create a Project under that org, but, I cannot.

If you see the org you were invited to in the XHR, then you should have access to the org in the platform.

What do you see when you hover over the org profile picture on the main dashboard page?

It should look something like this,

Screenshot from 2024-05-25 16-40-59

Aha - something seems to have changed. Before, when I clicked on that, there was only the Personal project, but now I see the org I was invited to. Perhaps some DB operation has had time to percolate through.

Thanks again for your help.

1 Like

Glad you’re all sorted!

For reference, here is what I was seeing.

This is taken from a browser window that is still open. I’m sure that if I refresh it, the new org will be there. The odd thing is, the org was created yesterday, and the invite was accepted yesterday, but that window is a new one from today. Apparently, in the last couple of minutes, the website has now started reflecting the new org.

Nevertheless, it works now. So, for anyone else seeing this thread, if you see what I have in my image, but not what elmstedt has above, then I guess just wait a day and keep refreshing the page.


I followed all the steps you provided. In the JSON response, I see the organization I was invited to, along with the default Personal organization. As you mentioned in your second reply, I can see my organization name when I hover over the profile picture on the main dashboard page platform.openai. com/ playground/.

However, the main problem is when I visit “chat. openai. com” At the bottom left corner, I can only see “Upgrade plan”. Instead of that, I am supposed to see my profile pic, and when I hover over it, I must be able to see my org name and change it to my org name, which is paid.
however i only see “Upgrade plan” there.

Your ChatGPT subscription has nothing to do with your API account.

They’re separate products altogether.

That’s not what I meant.

When I log in with my account on “”, I am only able to access my personal account. I can’t find any option to switch to my organization account, which is paid.

The same is true with my mobile app.

How can I switch from my personal account to my organization account on “”?

You can’t.

It reads like you were invited to an API organization, not a Teams Workspace.

If you see the organization in the platform page, that’s where the organization is.