Severe Memory Consumption with ChatGPT Tab on Browsers

For the past week, I’ve been experiencing severe memory consumption issues with the “ChatGPT” tab on browsers like Chrome and Edge. It doesn’t matter which browser I use; the memory usage skyrockets. The service works smoothly on my phone, but due to work requirements, I need to use it on a browser.

Simple queries are fine, but whenever I ask it to perform more complex tasks, it completely overloads my RAM. I’ve calculated the average completion time, which varies from 1 minute to as much as 6.5 minutes.

6.5 minutes is a long time. Trying to work efficiently is impossible because the flow is completely disrupted. I end up having to take a break, make tea or smoke, and by the time I get back, I’ve lost focus and forgotten my original question, so I have to start over.

I’ve seen other users report the same issue on forum, but there seems to be no response for that issue from the team.

1 Like

It’s interesting that the issue is specific to browser usage, as it works fine on your phone. The long completion times and high memory usage are definitely causing disruptions to your workflow.

Have you tried a few troubleshooting steps?

  • Check browser extensions: Disable any unnecessary extensions, as they might be contributing to the issue.

  • Browser updates: Ensure your browsers are up-to-date.

  • Cache clearance: Clear browser cache and cookies.

  • System resources: Close other resource-intensive applications.

If these steps don’t help, you might want to consider reaching out to the ChatGPT support team directly, as you’ve noticed other users with similar issues. They may be able to provide more specific guidance or bug fixes.

https://community.openai.com/t/chat-gpt-server-down-steps-followed-for-fix/799501?u=rajatsurana979

check this out

I have been having the same issue over the past week. I have tried on Chrome, Firefox, and OperaGX. OperaGX manages it decently, but the issue persists; on Chrome and Firefox, I get out of memory errors that shut down the browser tab. I have noticed that if I press the square icon Stop button in the chat input, that it will often “catch up” with a lot of the response that I would’ve been waiting for minutes on end for otherwise.

This seems to be especially terrible when using custom GPTs, but really anything with a long-enough context window is subject to the issue with GPT 4o. I often switch over to GPT 4 to continue on with my queries, but I don’t know if this also has the issue; I have only been using it to get answers when 4o overwhelms my browser. I have not been using GPT 3.5, so I cannot confirm anything there.

This happens at home with a lot of extensions installed, and at work where I have only the Adobe Acrobat and Google Docs offline extensions installed. In both locations, I’m on Windows 11 machines.

I confirm this is not related to the current outage (even if the current outage motivated me to show up here to log this :yum:)