Quota exceeded error only in Assistant APIs

I’m getting:

      "last_error": {
        "code": "rate_limit_exceeded",
        "message": "You exceeded your current quota, please check your plan and billing details."

ONLY in Assistants API runs.

After checking my billing information and my rate limits, I think I didn’t exceed the quota. And I tried the completion API, everything works. This error is only occurring with Assistant APIs. I tried using another thread, model, or assistant instance, but the error still occurred.

The assistants is designed to fill the models entire context with conversation threads and documents and then iterate on functions. That you exceed your rate limit means it is trying to spend the maximum you can spend per minute on low-cost input vs output without its own rate limit monitoring.

DOS attack? they probably DOS’d themselves…

I’m facing the same issue with a very simple setup.

I just figured out this for my own situation:

I use my email for multiple different organizations. All the organizations my account joined have bill information ready, but one of them is my personal one, and I don’t use it anymore, so I set its limit to 1 dollar.

After joining a new organization with a relatively higher limit, I was actually still using my personal account until I switched to the default organization here: OpenAI Platform .