Pressing enter no longer submits

I have to manually click the little paper airplane to submit my prompt. Enter no longer works. I tried a lot of stuff, even clearing my cache. I’m going to try restarting my browser/computer next, but this seems to keep coming back.

At first this seemed to be intermittent but now it just flat out doesn’t work.


Same here, but… if my browser window is full screen, it works just fine. If my browser is resized / or on mobile, it doesn’t work. I can only assume it is a protection against accidentally submitting by hitting enter on mobile, but having the ability to customize this would be great!

I’ve just tried on Edge Dev, it seems that return to send does not work when you reduce the width of your browser window until the sidebar on the left disappears.
When you increase the width such that it appears again return to send works again. I agree, that return to send should be the standard on any size screen, because often i just have ChatGPT open in the Edge sidebar to not take up to much screen estate whilst doing some research on the web.

1 Like

That’s it! Man this has been driving me nuts. As it happens, I usually resize ChatGPT just to where that sidebar disappears because I can’t find any other way to make it disappear. It’s funny because resizing it to this point actually gets you the WIDEST POSSIBLE chat line width (no matter how wide you make the window, line width will always be smaller than at this just-small-enough-to-collapse-sidebar width).

I hope they make the UI better. They made some awful design choices… but at least now I know why I can’t hit enter to send. Thanks guys!

+100 to this feature request

For my multi-tasking workflow, I keep a small ChatGPT window on the side of my main window (e.g. writing a doc), and it’s really frustrating to keep moving my mouse to submit queries.

Here’s a really simple solution to this problem (which is already used by several apps including this forum where I am typing this message): use “ctrl+enter” or “cmd+enter” to send.

I have been having the same issue. I tried everything and nothing works.


Hello. This was a big problem for me. I solved it with this Tampermonkey script: when Ctrl+Enter is pressed, it clicks the button by identifying it with its class. Maybe it works for you too.