OpenAI usage endpoint 429 error

Until couple of days ago this endpoint was working fine v1/usage?date=2023-06-29 .

Now, it’s giving 429 errors when doing more than one concurrent request. I tried to batch the request and wait x milliseconds between small batches, but still the same issue.

Any help? Or this API is just not usable anymore.

1 Like

It’s not a documented endpoint as far as I am aware, I think it was discovered by @DutytoDevelop and posted/unofficially documented on the forums.

Bearing that in mind, it could be simply a transient outage/issue or a depreciation/rate limit placed on it.

1 Like

Hi. As I see, the endpoint v1/usage is working fine with a rate of 5 requests per minute. It doesn’t return the deprecation message like /dashboard/billing/usage does. Is it indeed an undocumented endpoint? I’m also looking for the response details.

Yes, there’s no documented billing/usage endpoints. Documented endpoints are here.

1 Like

Hi, I’m a new user of chatgpt api. I registered yesterday (July 30, 2023)
I tried the example project (openai-quickstart-node.git)
and on the first try I got an the 429 error.
in my account Usage page I see:

Grant 1 $18.00 Expired May 1, 2023

is that the way it should be?
is there a way to try the api without upgrading to paid plan?

Welcome to the developer forum!

It seems that you created your OpenAI account prior to May 1st 2023, Your API account is automatically created when you first sign up to OpenAI, even if that is for ChatGPT.

If you add a payment method to your account detail in the billing section, you will then be able to access the API endpoints.