🔍 [New Plugin] Google Search: Use Google with ChatGPT

Stumbled upon this open-source ChatGPT plugin GitHub - Sogody/google-chatgpt-plugin.
Tested it out and it’s as good as Bing, if not better.

1 Like

I couldn’t get this to return results in localhost. Two questions:

  1. Did you deploy via Heroku?

  2. For the Search Engine ID - confirming the one that works for you is an alphanumeric “i.e 12ec50938fd084620” and not with a : like the older versions?

Help if you can :slight_smile:

  1. There is an option to deploy to Heroku. That seems to work well for me, however I did have to add env variables to Heroku.
  2. Yes, that’s correct. It’s an alphanumeric ID. You also need the GOOGLE_API_KEY though. The links to get that info is in the readme.

Hope this helps :slight_smile:

1 Like

Nice finding. Unfortunately I have problems with instaling this plugin. In Heroku I set API and GoogleSearch keys. When I am deploying it I have:

Found plugin

:white_check_mark: Validated manifest

:x: Errors in OpenAPI spec

None of the provided servers is under the root origin https://my-app.herokuapp.com

Server URL http://localhost:5000 is not under the root origin https://my-app.herokuapp.com; ignoring it

When I am checking manifest file I see correct urls, but idk why I see this inside OpenAI spec and how to change it without deployment everything locally:

None of the provided servers is under the root origin https://my-app.herokuapp.com
Server URL http://localhost:5000 is not under the root origin https://my-app.herokuapp.com; ignoring it
{
“openapi”: “3.0.3”,
“info”: {
“title”: “Google Search Plugin API”,
“description”: “A Flask app that uses the Google Custom Search API to search the web.”,
“version”: “1.0.0”
},
“servers”: [
{
“url”: “http://localhost:5000
}

(…)

Is it possible to change OpenAPI spec? Probably this is a problem. From another hand - if You @sgz deployed it with success then error is maybe in another place :confused:

1 Like

The Server URL http://localhost:5000 should be changed to the deployment url I think. I must’ve changed the servers[0].url to my deployed URL in /.well-known/openapi.yaml before deploying to Heroku.

Seems it has been updated, cloning the latest main branch and redeploying should now do the job :slight_smile:

Thanks for your response. I made clone, I changed localhost to Heroku address and I was able to add this plugin to my chatGPT, but unfortunately when I am using this plugin:

RESPONSE FROM GOOGLE SEARCH PLUGIN
<!doctype html>
<html lang=en>
<title>404 Not Found</title>
<h1>Not Found</h1>
<p>The requested URL was not found on the server. If you entered the URL manually please check your spelling and try again.</p>

Any idea how to fix it?
Screenshot:

1 Like

There’s a newer version I think, there was an openai yaml update, which most likely fixes this. Just tested it out myself with the latest update and seems to be working well now. Give it another deploy with the latest changes and feel free to share any issues :slight_smile:.

1 Like

If you’re looking for another option, please consider our MindfulDataAI dot com plugin. It adds Google Search to ChatGPT and is free.

My team has a free plugin in the store called MixerBox WebSearchG that lets you search using Google Search API, and it has also integrated ChatPDF into the same plugin for your convenience.

1 Like