Issues with Azure Assistant API File Search and Response Times

I am currently working with the Azure Assistant API and facing some challenges. Specifically, when I attempt to add files and utilize function calls, the file search functionality does not work as expected. Despite providing proper instructions, the API often responds with “I don’t have the information,” even though the necessary data is available in the files.

I have tested this with GPT-3.5 Turbo, GPT-4, and GPT-4 Turbo, but the problem persists across all models. Additionally, the response times are significantly longer compared to the standard OpenAI Assistant API, which performs well in terms of file search, function calls, and response times.

I need further support on this issue. I am currently working with the Azure Assistant API and facing some challenges. Specifically, when I attempt to add files and utilize function calls, the file search functionality does not work as expected. Despite providing proper instructions, the API often responds with “I don’t have the information,” even though the necessary data is available in the files.

I have tested this with GPT-3.5 Turbo, GPT-4, and GPT-4 Turbo, but the problem persists across all models. Additionally, the response times are significantly longer compared to the standard OpenAI Assistant API, which performs well in terms of file search, function calls, and response times.

I need further support on this issue.

Yes lot of issues on the azure side. Try the chat completion api with files indexed in ai search snd experiment with temperature values in the playground to see how it performs.