Insufficient_quota error occurred even though the usage is way lower than the limit


I cannot make any api call due to:
openai.RateLimitError: Error code: 429 - {‘error’: {‘message’: ‘You exceeded your current quota, please check your plan and billing details. For more information on this error, read the docs:’, ‘type’: ‘insufficient_quota’, ‘param’: None, ‘code’: ‘insufficient_quota’}}

I had my payment set up and it worked for several months. Here is my usage:

I noticed there is a $0.1 granted credit, maybe something is wrong in billing process and thinking that $0.1 credit is my limit? I also see there is -$0.06 in my billing page.

Do I have to enable auto recharge? Does that mean I have to pre-pay to unlock my account?

EDIT: Read prepaid billing article in official website, notice if we don’t use the credit we prepaid, it will expire after 1 year. And they removed pay-as-you-go billing method for most of API users? Probably I am the last one who know this, but this make me feel really bad as a customer.

1 Like

Heya! OpenAI switched to pre-pay for a lot of accounts. You should’ve gotten an email.

You just need to pre-purchase credits now.

1 Like

Thanks Paul, I saw the email. I am ok with prepaid, but setting a lower bound of money prepaid and force our credit to be expired is not looking correct. Please correct me if I misunderstood the policy.

Here is what I am thinking:
OpenAI becomes a big company and has huge impact to the ML community or even the whole world. You as a company can ignore those individual developers who are working on light duty task, because there is not much profit you can get from them. They probably only use low-end model and spend less than $5 per year, but they continue to contribute to the community as you do, akin to individual wildfires blazing with impact. Please remove credit expiration or allow us to pre-pay any amount of money as we want. It doesn’t make sense if you combine them together.

1 Like