I still get an error 'You exceeded your current quota'!

My credit balance is $20 now. Actually I paid it a few hours ago. So my current tier is usage tier 1 and my usage limit is $120. (It was free tier)
But, I still get the error saying ‘Error Message: You exceeded your current quota, please check your plan and billing details. Error Type: insufficient_quota’, when I call ChatGPT(gpt-3.5-turbo-0613).
What am I missing?

One strange thing is that the ‘Credit Grants’ on the Usage page still has a pink (Expired) area. I’m not sure but shouldn’t the pink part have been erased?
Please help!

as far as I know, the best way of checking if you still have credits is at https://platform.openai.com/account/billing/overview
There you can see if credit balance > 0
Yesterday I had the same issue, it took half an hour before I could rerun my calls to openai.

Also, with me there is also pink. I believe this is un related to how much credits you have. I think this expired is related to you trial period with might only have been valid a certain period. Again, making assumptions here…

It’s been half a day since I paid. My credit balance is $20 now and auto-recharge is on. I still get the same error. What’s wrong with me? ^^
Thanks for reply anyway. Need to find out ASAP…

what does it say under setting>billing>credit balance?

Pay as you go
Credit balance
Auto recharge is on

mmm, that’s a bummer. Hope you’ll get it fixed soon!

Yes. Thank you for your encouragement!

1 Like

@dries,ketels Hi, I got it fixed by creating new api key. Thanks for your concern.^^