GPT with a privacy policy Action configured still gets 'Public actions require valid privacy policy URLs' error when trying to publish GPT as public

I created a GPT that has an Action configured. When I tried to make it public it asked for a privacy policy, so I added a privacy policy to the GPT. I then verified that the GPT can access the privacy policy by asking it to tell me what the GPT privacy policy is, and it is able to call the privacy policy Action that is configured. Unfortunetly when I try to make the GPT public, it still shows the ‘Public actions require valid privacy policy URLs’ ’ error.

I thought everything was configured correctly as the GPT could call the privacy policy endpoint configured in the schema (which is just the GET to the privacy policy URL), and there is even a GET method that is shown to be available

Available actions
Name	Method	Path	
getPrivacyPolicy	GET	/live/e32af18d-a63c-45ac-879d-c1b05fd0f31a

Anyone else have similar issue, or know how I can identify what might be off?

I posted this after spending a few hours trying to solve it, and of course 20 minutes after submitting the post I figured it out. I will share why this happened, and how I solved it.

When I tried to publish my GPT as public, the full error that is displayed is as follows:
-‘Public actions require valid privacy policy URLs. Click here to update.’

When you click the ‘Click here’ link, it creates a new Action, whish is where I thought you had to create the Privacy Policy definition. THAT IS NOT CORRECT. You just have to go to your existing defined Action, and add the privacy policy URL at the ‘Privacy policy’ section at the end of the Action definition.

I hope this helps others!