Myfiles_browser tool is not operational for these files

I’m trying out the new Assistants API in the playground. Have uploaded a bunch of files, but they are not being accessed.

" myfiles_browser tool is not operational for these files"


I have also encountered this problem and urgently need to solve it


“I’m sorry, but it seems there is an issue preventing me from accessing the file you’ve uploaded using the myfiles_browser tool. Could you please re-upload the file, or provide it in a different format if possible?”

When I look to validate that the file exists, I can find it with the files api but not with the assistants files api. However, if I try to retrieve it with the files api it fails.

 josh@host:~/git/myrepo$ curl$ASST_ID/files/$FILE_ID  -H "Authorization: Bearer $OPENAI_API_KEY
" -H 'Content-Type: application/json' -H 'OpenAI-Beta: assistants=v1'
  "error": {
    "message": "No assistant file found with id '<redacted>'.",
    "type": "invalid_request_error",
    "param": null,
    "code": null
 josh@host:~/git/myrepo$curl$FILE_ID -H "Authorization: Bearer $OPENAI_API_KEY"
  "object": "file",
  "id": "<redacted>",
  "purpose": "assistants",
  "filename": "upload",
  "bytes": 689426,
  "created_at": 1699471852,
  "status": "processed",
  "status_details": null
 josh@host:~/git/myrepo$ curl$FILE_ID/content -H "Authorization: Bearer $OPENAI_API_KEY"
  "error": {
    "message": "Not allowed to download files of purpose: assistants",
    "type": "invalid_request_error",
    "param": null,
    "code": null

Just to be sure, I also tried adding the file_ids to the assistant to make assistant_files, not just attaching to a message in a thread. Same errors.

This is with PDF files.

1 Like

I am also getting this error. “The system indicated that the files were not accessible with the myfiles_browser tool, which is necessary for me to read their contents and assist you further.” Any idea how to solve this?

I have seen the myfiles_browser message, but now I am also seeing this:

Based on the initial content of the document titled “Executive Order on the Safe, Secure and Trustworthy Development and Use of Artificial Intelligence,” the following text has been developed. Unfortunately, without the full text, only the first 7% is available.

I am also seeing this issue. I can still interact with the files using OpenAI threads UI.

But I cannot seem to use the assistant in my own API/UI without this error.

Seems like some sort of config issue on OpenAIs side. I hope they will patch it soon, there is nothing in the docs that can point to a fix.

1 Like

Doesn’t work for me neither. The initial loading of the file works quite good. But changing the files like replacing them made this error. Doesn’t sound so stable as per ‘Preview’ indicates.

I actually seem to have been able to fix this. It seems like I was not using the API correctly, I believe I was trying to execute the run before creating a message properly. So it would try to execute a run without any messages, which caused this weird response.

Did you permanently fix it? What was the fix?

I am certainly creating messages each time…sometimes it can read a doc and sometimes it cannot. It screams “eventual consistency” cloud storage bug.

I get the same error too, but it seems random. Some times works other times via Assistant API throw this error: This file is NOT accessible with the myfiles_browser tool

Via plyaground i can see all the files correctly uploaded with status=ready and threads is working with no error.
Did you figure out what could be the problem?

Ya same issue it seems kinda random right now… sometimes it works sometimes it doesn’t playground and API.

1 Like

So far the only way I can get it to consistently work is if I just upload one file from the start. Then I can keep adding one at a time. ( Playground and API )

I’m also getting the same error from API:

It seems you’ve uploaded a file, but there currently seems to be an issue accessing it with the myfiles_browser tool. This may be a temporary issue.

However, it’s working fine from the playground.

Same issue for me. Works in Playgrounds but not via API.

I see that you have uploaded two files, but currently, I cannot read or analyze these files as they are not accessible through the tool I have available (myfiles_browser). If you want me to help you with the files’ content, please upload them again and ensure they are accessible through the myfiles_browser tool.

1 Like

I have a work around.

First, change your assistant config tools to this:[{"type": "code_interpreter"}]
Uploaded files also works with code_interpreter mode and actually works compared to retrieval.

When creating your message. You need to specify in your message content (prompt): “output as a saved csv file with accessible”
also reference the like so:
in the message parameters.

run the thread and once it is completed, it should return a file_id. This is how i retrieved the file_id: client.beta.threads.messages.list([0].content[0].text.annotations[0].file_path.file_id
once you have the file_id just simply return the content of the file with this: client.files.retrieve_content(file_id)

Hope this helps

I’ve got some success with just adding another message to the thread and saying something to the effect of “Yes you do have the files, I attached them in the initial prompt (or wherever you may have attached them).”. The model seems to then generate a response to what I was initially asking.

I found that some of my files had character sequences that, when handled incorrectly in python, turned into control characters. I changed my preprocessing to ensure that they would be treated as escaped characters when read as utf-8 encoded files and have much higher success.

The struggle with this particular bug is that it feels so random that it’s hard to tell when something you changed (eg. a prompt tweak or code implementation) actually improves the outcome or if it just happened to work that time. Is there a way to get in touch with OpenAI devs to ask for support or to check on the status of bug fixes?

1 Like